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1 Introducing Cloth
About Cloth overview

With Cloth, you can create realistic animated cloth within the Maya 
environment. Cloth gives you the ability to model garments for any 
animated 3D figure, apply dynamic effects, and simulate the cloth 
behavior. 

In addition to clothing characters, you can create many other types of 
cloth animation, including sheets, bedding, drapery, flags, and fabric 
goods of all kinds.

To help you learn how to create clothing, we’ve included lessons in 
Chapter 3, Cloth, of Getting Started with Maya Unlimited. We recommend 
that you do this tutorial before starting to work with Cloth.

Related topics

“Load Cloth”

“Creating cloth”

Stuart Little image courtesy of 
Sony Pictures Imageworks. 
Columbia/TriStar. All rights 
reserved. 
Cloth
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1 | Introducing Cloth
How do I? > Load Cloth
How do I? Load Cloth

When you start Maya, Cloth is automatically loaded. You can also load 
and unload Cloth using the Plug-in Manager.

To turn off Cloth autoload

1 Select Windows > Settings/Preferences > Plug-in Manager.

2 In the Plug-in Manager window, turn off the auto load checkbox for 
CpClothPlugin.so (IRIX and Linux) or CpClothPlugin.mll (Windows).

Now, when you start Maya, Cloth is not automatically loaded.

To turn on Cloth autoload

1 Select Windows > Settings/Preferences > Plug-in Manager.

2 In the Plug-in Manager window, turn on the auto load checkbox for 
CpClothPlugin.so (IRIX and Linux) or CpClothPlugin.mll (Windows).

Now, when you start Maya, Cloth is automatically loaded.

To unload Cloth

1 Select Windows > Settings/Preferences > Plug-in Manager.

2 In the Plug-in Manager window, click the loaded checkbox for 
CpClothPlugin.so (IRIX and Linux) or CpClothPlugin.mll (Windows).

Maya unloads Cloth.

To load Cloth

1 Start Maya.

2 Select Windows > Settings/Preferences > Plug-in Manager.

3 In the Plug-in Manager window, click the loaded checkbox for 
CpClothPlugin.so (IRIX and Linux) or CpClothPlugin.mll (Windows).

Maya loads Cloth and adds the Cloth menu set.

You can access Cloth’s features from the Cloth menu set, or from the 
Hotbox.

Note If you exit Maya using the quit -force command, temporary 
files may be left in the directory specified by the TMPDIR 
environment variable. If that variable is unset, any files are 
left in your /tmp directory.
Cloth
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How do I? > Load Cloth
To select the cloth menu set

Click the menu selector in the status line and select Cloth from the 
pull-down menu.

The Cloth menu set is displayed in the menu bar.
Cloth
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2 Creating Cloth
About Creating cloth

With Cloth, you can create a simple piece of cloth, such as a tablecloth or 
flag, or a complicated article of clothing that is fitted on a model. 

There are two ways to create clothing:

• “Create a garment”

• or for a simple piece of cloth, like a tablecloth, you can “Create a cloth 
object”

Related topics

“Differences between a garment and a cloth object”

How do I? Create a garment

The basic workflow for constructing a garment is similar to the way a 
tailor makes clothing. 
Cloth
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2 | Creating Cloth
How do I? > Model the character
• You create cloth panels by drawing a closed region of curves on a 2D 
plane. 

• You sew individual panels together by specifying seams on the panel. 

• You specify material properties and resolution values for each panel. 

• When the garment is constructed, you simulate it using the cloth 
solver.

The final product is a 3D fabric triangle mesh consisting of 2D panels 
sewn together. 

Model the character

When you model the character that will wear the garments you are 
creating, you need to anticipate your solver scale. You set the solver scale 
to take into account the size of your models. The solver scale makes cloth 
behave as though it were a different size, so if you have a small character, 
the cloth behaves as though it were real-world size. 

Understand solver scale

When you drape a garment onto a model, the cloth solver runs the 
simulation that drapes the garment. By default, the cloth solver works in 
terms of real-world units. To change how the cloth solver interprets the 
size of the model and the cloth, you change the solver scale.

The solver scale is 1 by default. When the solver scale is 1, you should 
model your character in real-world sizes. For example, a human being is 
about 160 centimeters tall and the typical length of a shirt is 60 to 70 
centimeters. You would therefore build a model of a human character to 
be about 160 centimeters tall and the character’s shirt to be about 60 to 70 
centimeters in length.

If you do not create the model in real-world units, you can change the 
solver scale to compensate. You can increase the solver scale to make the 
cloth behave as though it were larger. For example, if you build a model 
Cloth
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How do I? > Pose the character
16 centimeters tall and increase the solver scale to 10, you get the same 
cloth draping solution as if your character was 160 centimeters tall and the 
solver scale was set to 1.

For information on changing the scale of the solver, see ”Scale the solver” 
on page 54.

Pose the character

You use the actual skin geometry as a 
mannequin to make the panels and fit the 
garment. You pose the mannequin in a dress-
up pose.

The dress-up pose places the body in a 
position that eliminates any self-collision and 
minimizes wrinkling in the initial fitting of the 
garment.

Build a pattern for the garment

The pattern for a garment consists of one or more panels that are sewn 
together. The panel is the basic building block of any fabric model.

Create curves

To create your garment, you first create some curves. The curves define 
the outline for the panels. The panels are seamed together to make a 
garment. 

To make a panel, you draw a closed region consisting of two or more 
NURBS curves. The curves must satisfy the following requirements:

• The curves must form a closed region. In 
other words, the last control vertex of one 
curve must be in the same position as the first 
control vertex of the next curve.

• They also must be coplanar, which means the 
curves are all drawn in a plane. 

You can create curves using either the CV Curve 
Tool or the EP Curve Tool. These are modeling 
tools available from the shared menu sets. We’ve 
provided a brief description of how to use these 
tools to create panel curves. For more detailed 
information on using these modeling tools, see the NURBS Modeling 
guide.

Dress-up pose
Cloth
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2 | Creating Cloth
How do I? > Build a pattern for the garment
Use the CV Curve Tool

The CV Curve Tool creates free-form curves. Use this tool when you want 
to create curved seams. When constructing curves using the CV Curve 
Tool, you must place several points to complete the curve, depending on 
the curve degree setting in the CV Curve Tool options window. 

The default setting for curve degree is 3. You need one point more than 
the curve degree, so you have to place at least four points to construct the 
curve using the tool’s default settings. 

Use the EP Curve Tool

When constructing curves with the EP Curve Tool, only two edit points 
are required to create the initial curve segment.

To create curves for a garment

1 Load your character model and 
display it in an orthogonal view. 

Drawing your curves in an 
orthogonal view helps make sure 
the curves are drawn coplanar.

2 Select the model, then right-click 
and select Actions > Template.

This makes the model a template. 
Templates are objects that you can 
see but cannot select. By making the 
model a template, you won’t 
accidentally select the model or modify it.

3 In the main toolbar, click  to turn on Snap to Curves. 

This snaps to curves and polygon edges. You can also press the c key 
to turn on Snap to Curves.

Tip You can use the Cut Curve tool to subdivide intersecting 
curves, which can save you time when modeling complex 
garments. See the NURBS Modeling guide for information 
on using Cut Curve.

Tip Hide any other polygons in your scene so you don’t 
accidentally snap to the wrong curve.
Cloth
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4 Set the curve tool options, if you want.

5 Select the curve tool you want to use: Create > CV Curve Tool or 
Create > EP Curve Tool. 

6 Position the pointer where you want the curve to begin.

7 Using the character model as a guide, click to place the first CV or edit 
point. 

8 Click where you want to place the second CV or edit point.

9 Keep clicking to add CVs or edit points and continue the curve

Remember, you need at least four clicks to create a CV curve.

10 When the curve is complete, press the y key. 

This finishes the curve and keeps you in the curve tool

11 Continue making more curves. You need at least two curves to create 
a panel.

Remember, each curve must touch the end of the previous curve.

To verify that the curves are attached at the endpoint

1 When you place the first CV or edit point in a curve you want to snap, 
drag it along the adjacent curve. 

If the CV or edit point is snapped to the curve, it will follow the path 
of the curve. 

2 Drag the CV or edit point to the end of the adjacent curve and release 
the mouse button.

Remember

If you construct a curve using the CV Curve Tool, you must 
place several points to complete the curve, depending on 
the curve degree setting in the CV Curve Tool options 
window.

Tip You can use Snap to Curve to verify that your curves are 
attached exactly at their endpoints (see the next section).
Cloth
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Duplicate curves

It is helpful to keep your patterns 
symmetrical. One way to do this is to 
create the curves for one side of the 
pattern, then duplicate the curves to 
create the other side. 

You can also duplicate the curves with 
instancing turned on. This way, if you 
adjust a CV on one side of the pattern, 
the same adjustment is made to the 
instanced CV on the other side of the panel.

To duplicate curves

1 Draw the curves for the right half of the garment. 

Make sure you snap the curve end points to the center grid. 

2 Select the curves and select Edit > Duplicate.

3 Select the curves and select Edit > Duplicate.

4 In the Channel Box, set the X Scale value to -1. 

The curves are duplicated and moved to the left side of the model.

Tip To make sure your curve end points snap to the center grid, 
turn on the snap to grid button or press the x key to snap to 
grid.
Cloth
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To instance the control vertices

1 Draw the curves for the right half of the garment. 

Make sure you snap the curves to the center grid. 

2 Select the curves and select 
Edit > Duplicate > .

3 In the Duplicate Options 
window, turn on Instance.

4 Click Duplicate.

5 In the Channel Box, set the X 
Scale value to -1. 

6 To adjust the curve, select a 
curve. Position the pointer 
over the curve, press the right 
mouse button and select 
Control Vertex. 

7 Select one of the control 
vertices and use the move tool 
to move it.

The instanced control vertex moves in conjunction with the selected 
control vertex.

Group curves

Grouping your curves is a handy way to organize your pattern. For 
example, if you are making a shirt, you might want to group all the curves 
that comprise the front of the shirt into one group and name it shirtFront. 
Cloth
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Then group all the curves that comprise the back of a the shirt into a 
group named shirtBack. You can then group the two groups into one 
group named Pattern.

To create a group of curves

1 Select the curves.

2 Press Ctrl-g to create a group.

3 In the Outliner, name the group.

4 Select Modify > Center Pivot.

This centers the pivot on the group so you can move the group more 
easily.

Position curves

Generally, you want to position your curves as close as possible to the 
body without intersecting the body. With realistic models, this is simply a 
matter of positioning the curves in front of and in back of the model. With 
exaggerated body shapes, you may need to pivot the curve group to place 
the curves as close as possible to the body.

To position curves on a realistic figure

1 Select the curves that will comprise a panel.

2 Press Ctrl-g to create a group.

You can name the group using the Outliner.

3 Select Modify > Center Pivot.

This centers the pivot on the group so you can move 
the group more easily.

4 Make sure the group transform is selected. Use the 
Move tool to position the group of curves as close to 
the body as possible without intersecting the body.
Cloth
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To position curves on an exaggerated figure

1 Select the curves that will comprise a panel.

Press Ctrl-g to create a group.

You can name the group using the Outliner.

2 Select Modify > Center Pivot.

This centers the pivot on the group so you can move 
the group more easily.

3 Make sure the group transform is selected. Use the 
Rotate tool to rotate the group of curves as so they 
more closely follow the general shape of the body.

Create panels

Once you’ve created all the curves for your garment, you can create 
panels out of the curves. A panel is defined as a closed set of planar 
NURBS curves. The curves must be planar and closed. Two panels can 
share curves.

To create panels

1 Select the curves that represent the portion of the garment you want to 
designate a panel (selection order is unimportant). 

2 Select Cloth > Create Panel.

A panel node is created.

Note If you delete a curve that makes up a panel, the panel 
becomes invalid.

Panel
Cloth
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How do I? > Create panels
What if you get error messages?

In order to create a panel or a garment, your curve must be planar, and 
they must make a closed loop. If not, you’ll get an error message. Here are 
some tips to help if you get an error message when you try to create a 
panel.

Curves must form a closed loop

If you get the message Error:Curves must form a closed loop when you try to 
create a panel, it means that the position of the last control vertex of one 
curve does not match the position of the first control vertex of the next 
curve. 

You can avoid this by turning on Snap to Curve or Snap to Grid when 
drawing the curves. To correct this, you can use the Move tool to snap a 
CV to another curve.

To make your curves a closed loop

1 Zoom in on your curve intersections to identify control vertices that 
don’t touch.

2 When you find two curves that look like they are not touching, select 
one of the curves. With the pointer over the curve, press the right 
mouse button and select Control Vertex.

3 Select the control vertex that is not touching the adjacent curve’s 
control vertex.

4 Select the Move tool.

5 Turn on Snap to Curve.

6 With the middle mouse button, click and drag on the curve you want 
to snap to. 

The selected CV will snap to the curve.

7 Drag the CV to the end of the curve.

Tip If your curves are grouped according to panel, you can 
select a single curve and press the up arrow key to select the 
group. Then select Cloth > Create Panel.

Tip You can also get this error message if you have selected 
curves that are on top of each other. This can happen if you 
have duplicated an extra curve. Check the Outliner to make 
sure you don’t have extra curves.
Cloth
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Curves must be coplanar

If you get the message Error: Curves must be coplanar when you try to 
create a panel, it means that the curves are not on the same 2D plane.

You can avoid this error by drawing your curves in an orthogonal view 
and turning on snap to view plane. Make sure you don’t accidentally 
rotate your curves.

To check for rotated curves

1 Select a curve.

2 In the Channel Box, make sure the values for Translate X, Y, and Z, 
and Rotate X, Y, and Z are set to zero.

3 Keep selecting and curves and checking the Translate and Rotate 
values in the Channel Box until they are all set to zero.

Seam the garment

Once you’ve created the panels, you can seam the garment. Remember, a 
garment is a collection of seamed panels.

Create the initial garment

You designate one of your panels as the initial garment. This triangulates 
the panel and creates the Stitcher, which lets you seam panels to the 
garment.

To create the initial garment

1 Select a panel and select Cloth > Create Garment. 

This tessellates the panel and creates a 
polymesh. A cloth node and cpStitcher node 
are created. You use cpStitcher to set the 
resolution of the garment (see ”Set 
resolution” on page 31).

You can also create the initial garment by 
selecting the curves and selecting Cloth > 
Create Garment directly instead of first 
creating the panel.

2 You can rename the garment using the 
Outliner.
Cloth
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Seam the panels

You add other panels to the initial garment by seaming them together. 
When the new panel is added to the garment, the mesh is retessellated. 

To seam the panels

1 Click  to turn off the Surfaces pick 
mask. 

This makes it easier to select the curves for 
seaming. 

2 Select a curve from the garment and Shift-
Ctrl-click a curve from the panel that you 
want to seam to the garment. 

One panel must be part of a garment.

3 Select Cloth > Create Seam to create a seam 
between these two panels. 

This tessellates the new panel and seams the two panels together.

4 Continue creating seams as desired.

Tips for seaming panels

If you are seaming a continuous boundary of panels that consists of 
several curves, the curves you seam must be contiguous.

For example, in the figure below the top panel’s edge is made up of two 
curves and the bottom panel’s edge is made up of three curves.

Tip If you change to shaded mode, you’ll see the garment more 
clearly.

Note The cpSeam MEL command now allows you to query the 
stiffness. In the Command Line or Script Editor, type:

cpSeam -query -stiffness;
Cloth
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• Curve 1 and Curve 3 are seamed together

• Curve 2 and Curve 5 are seamed together

• Curve 4 is not seamed

This is an invalid seaming operation and can cause errors when you 
change the resolution of the panel.

To correct this

1 Do one of the following:

• Seam contiguous curves. For example, seam Curve 1 to Curve 3, 
and seam Curve 2 to Curve 4

• Remake your curves so the number of seams match. For example, 
delete curve 4, and extend curve 3 and curve 5 so they meet.

Tailor with darts

A dart transitions a garment from a part of the body that is larger to one 
that is smaller. For example, from the bust to the waist or from the hips to 
the waist are areas that commonly use darts. Pleats and gatherings can 
also perform this same function.

You can seam together curves from the same panel to create darts in 
clothing.You shape the panel so the area that would be overlapping in a 
real garment with a dart is not included in the panel. You can use the Cut 
Curve modeling tool to help create darts.

Curve 2Curve 1

Curve 4Curve 3 Curve 5
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To create darts with the Cut Curve tool

1 Draw the curves for your garment.

2 Draw the curves representing the dart seam.

3 Select the curves attached to the curve you want to delete to create the 
cut for the dart.

Create a panel allowing 
space for the dart

Seam the edges of the 
panel

Simulate the cloth to create the 
shape of a garment with a dart
Cloth
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4 From the Modeling menu set, select Edit Curves > Cut Curves > .

5 In the Cut Curves options window, make sure All Curve Segments is 
turned on.

6 Click Cut.

7 Select the curve you want to delete.

8 Press Backspace to delete the curve.

This curve 
will be 
deleted
Cloth
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9 Make the curves a panel or garment.

10 Select the two seams for the dart and select Cloth > Create Seam.
 

When you simulate the cloth, the seam will be drawn together to form 
a dart.

Adjust the garment

This section describes changing the shape of a garment before simulating. 
If you want to change the shape of a garment after you have simulated, 
see ”Modify the panel after simulating” on page 51.

Change the shape of a panel 

You can change the shape of a panel in a garment and the panel will 
retessellate. 
Cloth
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To change the shape of a panel

1 Select Simulation > Disable Solver.

Disabling the solver is not required but it 
makes it easier to adjust the curve.

2 With the pointer over the curve, press the 
right mouse button and select Control 
Vertex.

3 Select CVs on the curve and use the 
Move tool to move them as needed.

4 Select Simulation > Enable Solver.

Move the garment

You can move the garment after you’ve created and seamed it by either 
moving the curves or moving the cloth.

To move a garment using curves

1 Select Simulation > Disable Solver.

This disables the solver and makes it easier to move the curve.

2 Select the curves that comprise the garment (don’t select the cloth).

3 Move the curves to the desired location.

4 Select Simulation > Enable Solver.

To move a garment using the cloth

1 Select the cloth mesh only (don’t select the curves).

2 Move the cloth to the desired location.

3 Select Simulation > Save as Initial Cloth State.

Set resolution

You generally want to set your resolution as low as possible when you are 
creating and simulating a garment. You can substitute higher resolutions 
later after you fit the garment. (See ”Modify the panel after simulating” on 
page 51.)

Tip You can change the shape of two seams at once if you 
instance the seams. See ”Duplicate curves” on page 20 for 
information on instancing curves.
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There are two ways to set the resolution of your cloth: for the entire 
garment or on a per-panel basis. If you sew together panels with 
dissimilar resolution, the lower resolution panel is further tessellated 
along the seam to match the resolution of the higher resolution panel.

To set the resolution of the entire garment

1 Select your cloth.

2 Do one of the following:

• Display the Attribute Editor 
and click the cpStitcher tab. 

• In the Channel Box, click 
cpStitcher.

3 Enter a value for Base Resolution. 

This represents the number of 
triangles in one meter of cloth. 

4 To stop the retessellation of your 
cloth, press the Esc key.

To set the resolution per-panel 

1 Select the panel.

2 Do one of the following:

• Display the Attribute Editor and 
click the panelShape tab. 

• In the Channel Box, locate 
panelShape.

3 Enter a value for Resolution Factor. 

This is a multiplier for the Base 
Resolution. If you set it to 2, this panel will have twice the resolution 
of the Base Resolution.

4 To stop the retessellation of your cloth, press the Esc key.

Adjust the seams

You can adjust several attributes that crease or round your seams. 

To select a seam

1 You can turn off the Surfaces and Curves pick masks to make 
selecting the seam easier.

2 Click the seam to select it.

 Setting garment resolution

Setting panel resolution
Cloth

32



2 | Creating Cloth

How do I? > Adjust the seams
Crease seams

If you want to have more control over your seams, you can specify a 
crease angle on a particular seam. This lets you have more control over 
things like lapels on jackets. 

To change crease angle and stiffness

1 Select a seam.

2 In the Attribute Editor or the Channel Box, enter values for the 
following:

Crease Angle

Specify a value between -180 and 180. A value of 0 creates no crease 
and gives you a flat seam. A value of 180 folds the cloth flat. Negative 
values fold in the direction of the normals.

Crease Stiffness

Lets you specify how much the crease should resist being pulled flat. 
The value you enter is a multiplier on the Bend Resistance attribute of 
the property. See ”Applying properties to Cloth” on page 63 for 
information on the Bend Resistance attribute.

Seam

Arrows indicates direction of normal

Crease angle of 90 Crease angle of -90 
Cloth
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Round seams

The Round Seams attribute tells the Stitcher to smoothly round the panels 
that are being seamed. If you turn Round Seams off, only the seam 
vertices are stretched. Round Seams is turned on by default.

The Round Seams attribute does not affect how the seam behaves during 
the simulation. It helps distribute the amount of stretch of the mesh 
triangles along the seam that extends to neighboring triangles. This helps 
decrease the amount of time required to relax the garment around the 
character (see ”Simulate cloth” on page 49).

To turn off round seams

1 Select your cloth and display the Attribute Editor. 

2 Click the cpStitcher tab. 

3 Click Round Seams to turn round seaming off.

If you change the Round Seams attribute after you have simulated, 
you must resimulate.

Model parts of a garment

If you are creating a garment that has a collar or other complicated 
subassembly, you can model and simulate a separate garment for the 
subassembly and merge it with the main garment.

For example, you can drape and fit a shirt around a character while 
independently building and simulating a collar as a separate garment. 
You position the collar near the shirt and seam it to the shirt. 

Round Seams offRound Seams on
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The two garments that are merged are called the source garment and the 
target garment. The first curve you select becomes the source garment and 
the second curve you select becomes the target garment. After seaming, 
the source garment’s Stitcher and cloth node are deleted and the source 
garment becomes part of the target garment.

The garments must be in the same solver when you merge them. If you 
create them using different solvers, you can transfer them to the same 
solver. (See ”Use multiple solvers in a scene” on page 120.)

To attach two garments

1 Create and simulate the main garment (target) and the subassembly 
garment (source) you want to attach.

2 If the target and source garments are in different solvers, transfer 
them to the same solver (see ”Use multiple solvers in a scene” on 
page 120).

3 Select the garment that you want to be the target garment and display 
the Attribute Editor.

4 Click the cpStitcher tab and turn on Fit To Surface.

5 If you need to move the subassembly mesh closer to the main 
garment, select the subassembly and use the Move tool to position the 
subassembly where you want it in relation to the main garment. With 
the subassembly selected, choose Simulation > Save as Initial Cloth 
State.

6 Select the curve on the subassembly that you want to seam to the main 
garment. 

This is considered the source garment.

7 Shift-Ctrl-click the corresponding curve to seam on the main garment. 

This is considered the target garment.

8 Select Cloth > Create Seam.

The source cloth node and its Stitcher are deleted and the source 
garment is seamed to the target garment.

Set display options

You can set your display options to hide or show cloth panels, panel 
curves, and seams.

To hide cloth panels, curves, or seams

• Select Display > Hide > Hide Cloth, and select All, Panel Curves, 
Panels, or Seams.
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To show cloth panels, curves, or seams

• Select Display > Show > Show Cloth, and select All, Panel Curves, 
Panels, or Seams.

Create a cloth object

If you are creating a simple piece of cloth like 
a sheet or tablecloth, you can either:

• create a polymesh or NURBS shape and 
make it a cloth object

• create curves that make a pattern for the 
cloth and create a garment

You can then add dynamic forces, add a 
collision object for the cloth to drape over, and 
run the simulation.

Differences between a garment and a cloth object

A cloth object is a piece of geometry simulated as cloth. If you select a 
NURBS shape and make it a cloth object, Cloth first converts the NURBS 
to a polygonal object.

A garment is one or more panels that are seamed together to form a cloth. 
(A panel is made up of two or more NURBS curves that are on the same 
plane and form a closed region.)

Garments

When you create a garment from curves, Cloth creates a mesh with 
varying sizes of triangles that are randomly distributed. The mesh has no 
regularity or stress lines. This creates more natural folds.

In addition, if you change the resolution of a 
garment after simulating, Cloth can update the 
geometry without resimulating. However, you 
need to simulate for the cloth to move with the 
new resolution.

All the constraints in Cloth apply to garments.

Cloth objects

You create cloth objects from polygonal shapes 
or NURBS shapes. The original shape is hidden 
and the tessellated cloth shape is displayed. The original shape and the 
cloth shape are grouped under the object’s transform. 

Garment tessellation
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With NURBS objects and certain procedurally-
generated polygonal objects, you can get 
artificial stress lines caused by the regular 
tessellation.

If you change the topology of the polygonal 
object after simulating, you have to 
resimulate.

Only the transform, field, and mesh 
constraints work on cloth objects. If you 
change resolution, you must reattach these 
constraints.

To create a cloth object

1 Select a polygonal or NURBS object.

2 Select Cloth > Create Cloth Object.

To change the resolution of procedurally-generated polygonal 
objects

Polygonal primitives are examples of procedurally generated polygonal 
objects.

1 Select the cloth mesh object.

2 In the Channel Box, select the history node.

3 Enter values for the subdivisions.

To change the resolution of a NURBS object

1 Select the cloth mesh object.

2 In the Channel Box, select the nurbsTessellate node.

3 Enter values for the U Number and V Number attributes.

Important Cloth objects originating from NURBS surfaces are 
inherently unstable in stressful environments due to their 
regular tessellation. Regular tessellations contain unnatural 
biases for bending, which can cause the surface to collapse 
when bent in those directions. We recommend that you use 
a cloth garment instead of a cloth object if the cloth will be 
put under stress, such as folding or significant stretching.

Cloth object tessellation 
of a plane
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Reference cpStitcher node

These are descriptions of the attributes in the cpStitcher node. For more 
information, see ”Seam the garment” on page 25, ”Set resolution” on 
page 31, ”Adjust the seams” on page 32 and ”Model parts of a garment” 
on page 34.

Base Resolution

This represents the number of triangles in one meter of cloth.

Round Seams

When this is on, the Stitcher smoothly rounds the panels that are 
being seamed. If Round Seams is turned off, only the seam vertices are 
stretched.

Fit To Surface

If after playing the cloth simulation you change the resolution of the 
garment, turn on Fit To Surface on to maintain the current shape. If Fit 
To Surface is turned off, the cloth will pop back to its previous shape.

cpSolver node

These are descriptions of the attributes in the cpSolver node.

Solver Attributes

These are the attributes in the Solver Attributes section.

Solver Enabled

Turns the current solver on or off. 

Cloth Collisions

Turns cloth-to-cloth collisions on or off. This affects cloth collisions in 
all the garments connected to this solver. To disable cloth-to-cloth 
collisions on a per-vertex basis, you use collision constraints (see 
”Create collision constraints” on page 88).

Output Statistics

Turn this on to output statistics to the Script Editor. Time to calculate 
each frame and the total calculation time is displayed.

Velocity Cutoff Min

Specifies a cutoff velocity for cloth vertices. If a cloth vertex is moving 
slower than this velocity (in distance per second), the solver sets the 
velocity to zero. The default value of Velocity Cutoff Min is 0, which 
means no velocity cutoff. You can use this to control cloth motion, see 
”Control cloth motion” on page 53.
Cloth

38



2 | Creating Cloth

Reference > cpSolver node
Velocity Cutoff Max

Specifies a second range of velocity cutoff. If the velocity of a cloth 
vertex is greater than the Velocity Cutoff Min and less than the 
Velocity Cutoff Max, then the velocity is damped toward zero. If 
velocity of a cloth vertex is greater than Velocity Cutoff Max, the 
vertex is not damped. You can use this attribute to control cloth 
motion, see ”Control cloth motion” on page 53.

Velocity Cutoff Damping

Defines the amount of damping if a cloth vertex has a velocity value 
between the Velocity Cutoff Min value and the Velocity Cutoff Max 
value. 

Damping of 0 is equivalent to multiplying velocity by 1/2 for each 
time step. The solver may take many time steps between frames as it 
adaptively determines a solution for the cloth. 

Damping of N is equivalent to multiplying velocity by 1/(N+2) for 
each time step. 

You can use this attribute to control cloth motion, see ”Control cloth 
motion” on page 53.

Start Frame

Specifies at what frame the solver starts calculating.

Frame Samples

Specifies the number of times the solver samples the time interval 
between successive frames. Frame Samples and Time Step Size work 
together. See ”Set frame samples and time step size” on page 54.

Time Step Size

Specifies the maximum time, in seconds, that the internal dynamic 
solution advances. Frame Samples and Time Step Size work together. 
See ”Set frame samples and time step size” on page 54.

Solver Scale

Specifies the scale of the internal coordinate system of the solver. See 
”Scale the solver” on page 54.

Time Scale

Determines the relative time Cloth is running with respect to the 
Dependency Graph time. For example, if you want the cloth to run 
through the simulation twice as fast, the Time Scale value should be 
set to 2. The longer the Cloth's simulation time is, the more force has 
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an effect on the Cloth. For example, ff the force is gravity, the Cloth 
will appear to be heavier as the Time Scale increases. The default 
value is 1.

Relax Frame Length

Specifies the number of frames that a rubbery “relax material” is 
applied to a garment and the garment does not react to gravity. After 
the specified number of frames, the normal material is applied and the 
cloth reacts to gravity. 

If you are creating a cloth object that does not need to be relaxed, such 
as a tablecloth, set the Relax Frame Length to zero.

If you are creating a cloth object that is really stretched out, you can 
increase this value.

Gravity

Specifies the value for gravity. If you want to disable gravity, set this 
to 0, 0, 0. The default is 0, -980, 0.

Cache Enabled

Turn this on to cache your simulation results to a file. For more 
information on caching, see ”Manage cache files” on page 98.

Cache Name

Specifies the name of the current cache. You can save cache files to 
different names and play them back. See ”Save and load cache files” 
on page 103 for more information.

Save Cache

The Save Cache button is beside the Cache Name attribute. Click this 
button to save the cache when you want to, ensuring that successful 
simulations are retained.

Cache Save Interval

Cloth simulation is often processing intensive and sometimes time 
consuming. By saving simulations in small increments this can often 
overcome situations where an entire simulation is lost. You can set the 
Cache Save Interval to any value. For example, if you set it to 10, 
caches will be saved every 10 frames during simulation.The default 
value is 0.

Clear Simulation Timer

Click the Clear Simulation Timer button to reset the internal timer of 
the solver. Timing statistics are printed to the script editor when 
Output Statistics is turned on.
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If you change your simulation and want to know if this speeds up or 
slows down your simulation, you can reset the timer before starting 
the new simulation and compare simulation times.

Adaptation Control

This controls what steps the solver can take when it reacts to a 
situation where it is having difficulty solving a simulation. Select an 
option from the drop-down list.

Adapt Frame Samples 

And Time Step This gives the solver full control over reaction. The 
solver will adjust frame samples and time step as it 
sees necessary to try to resolve the problem.

Adapt Time Step This limits the solver's reaction to adjusting the time 
step variable.

Stop Solver This tells the solver to halt and release control to the 
user. A MEL script is executed if it is defined by the 
user. 

No Action This tells the solver not to react. 

monitorScript

Specify the monitor control script, also known as the MEL callback 
script. If a script is defined and the solver has not been able to resolve 
a failing simulation, or Stop Solver is specified for Adaptation 
Control, then the script assigned to this string will be executed. For 
more information, see ”Monitor script parameters” on page 117.

Collision Object Debug

These are the attributes in the Collision Object Debug section. For more 
information, see ”Debug cloth collisions” on page 58.

Show All, Hide All

Shows or hides all meshes.

First, Last, Previous, and Next

Use any of these to view the appropriate group of meshes and hide 
the previously viewed group (if any). First select Hide All (of the 
meshes) and then use these buttons to step through the subframes. 

Deprecated Attributes

The Deprecated Attributes section contains attributes that are no longer 
used, but are kept around for backwards compatibility purposes. When 
old scenes are loaded into Maya, Maya checks for these old attributes and 
copies them to new attributes/nodes.
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Cloth > Create Panel

Use this to create a cloth panel from the selected curves. For more 
information, see ”Create panels” on page 23.

Cloth > Create Garment

Use this to create a cloth garment from the selected panel or curves. For 
more information, see ”Create a garment” on page 15.

Cloth > Create Seam

Use this to create a cloth seam from the selected curve(s). For more 
information, see ”Seam the garment” on page 25.

Cloth > Create Cloth Object

Use this to create a cloth object from the selected polygon. For more 
information, see ”Create a cloth object” on page 36.
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About Draping and fitting

After you create the garment, you drape it and fit it to the character. To 
drape the garment on the model, you specify the model as a collision 
object and use the cloth solver to drape the garment over the model. 

Fitting involves modifying the original garment to accommodate 
peculiarities of the character on which it is draped. You can influence how 
the cloth settles on the character using constraints and dynamic fields. For 
example, you can pull out wrinkles or pin portions of the garment to 
specific places on the character. You can assign different properties to the 
panels and set various attributes of the cloth to change the physical 
behavior of the cloth. 

Once the garment has settled, you can save this initial position of the 
garment and begin animating. 

How do I? Create cloth collision objects

In order for your cloth to drape over your model or an object, you need to 
make it a collision object. When you make an object a cloth collision 
object, Maya connects it to the cloth solver and adds collision object 
attributes. 

Tip If you have a complicated scene, you can segment the cloth 
simulations into multiple independent simulations that are 
solved separately. You do this by using multiple solvers. 
This chapter covers draping and fitting using a single 
solver. To use multiple solvers, see ”Use multiple solvers in 
a scene” on page 120.
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Polygonal objects, NURBS, and subdivision surfaces can all be used as 
collision objects. If your model is a NURBS object or a subdivision surface, 
Maya automatically converts it to polygons when you make it a collision 
object.

To create a cloth collision object

1 Select the object you want to be a collision object. 

If you have templated your model, select the model from the Outliner.

2 With the model or object still selected, select Cloth > Create Collision 
Object.

The object is made a collision object and connected to the current 
solver. Collision object attributes are added (see ”Adjust the cloth 
collision object” on page 44). 

Now, when your cloth evaluates, it will collide with the collision 
object.

Remove collision objects

You can remove a collision object from the solver. However, the collision 
object attributes remain. That way, you can temporarily remove a collision 
object from the solver and add it back without losing the collision object 
attribute settings.

To remove a cloth collision object

1 Select the collision object.

2 Select Cloth > Remove Collision Object.

Adjust the cloth collision object

The collision object attributes help determine how the cloth collides with 
the collision object.

To adjust the collision object attributes

1 Select the collision object.

2 Do one of the following:

Tip This section covers using collision objects with a single 
solver. For information on using collision objects with 
multiple solvers, see ”Use collision objects with multiple 
solvers” on page 122.
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• Display the Attribute Editor, click the nameShape tab, and open 
the Extra Attributes section.

• In the Channel Box, locate the collision attributes.

3 Enter values for the following:

Collision Offset

Specifies the distance the cloth stays from the collision object. The 
default is 1. If your character is small, for example 10 cm high, you 
might want to decrease this value. 

Collision Offset is measured in centimeters and is not affected by the 
solver scale. If you specify a value of 2, the cloth stays 2 centimeters 
from the collision object.

Collision Depth

Specifies the distance the cloth can penetrate the collision object and 
still be repelled. Once the cloth is past this threshold, the collision 
object won’t try to repel the cloth. This value should not be greater 
than half the distance from one side of the collision object to the 
opposite side of the object. In this case, the cloth may be pulled 
through the object. The depth is measured in centimeters and is not 
affected by the solver scale.

Collision Depth is applied to an entire collision object, which may not 
be appropriate for complex objects such as human bodies. If finer 
control of the collision depth is desired, then turn on the Depth Map 
Enable checkbox on the collision object for a single frame in the first 
few frames of the cloth simulation. This will generate a depth map 
based on the shape of the collision object. If you still want finer 
control, you can paint offsets to the generated depth map using the 
Cloth > Paint Collision Properties Tool.

Note Depth Map Enable and Depth Map Offset (Paint Collision 
Propreties Tool) should only be used if a simulation is 
incorrect and vertices are sticking inside the collision object. 
These options cannot be used to adjust the simulation 
results.

Important!

Make sure the surface normals of the collision object face 
the outside of the object. If the normals face to the inside of 
the object, intersecting cloth will be pulled into the object.
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Collision Priority

Collision Priority controls how pinched cloth vertices are handled 
during collisions. If you want a collision object to take priority over 
another collision object, you set the Collision Priority attribute. 

A lower value takes priority over a higher value. The default value is 
1. You can set values to positive or negative short integers. We 
recommend you use values of 1, 2, or 3. In most cases, you only need 
to use values of 1 and 2. 

For more information, see the next section, “Control pinched cloth.”

Depth Map Enable

When turned on, this scans the collision object and calculates the ideal 
collision depth for each face on the object. A new depth map is 
generated for each frame so this can be expensive to use. This attribute 
is located in the Extra Attributes section of the collision object’s shape 
node in the Attribute Editor.

Depth Map Weight

This value is multiplied by the depth map value for each face, 
resulting in the depth map actually used by Maya. Generally the 
depth map weight should be left at its default value of 0.3. Raising 
this above 0.3 will result in a deeper depth map, but increase the 
possibility of erratic or unstable simulations. Lowering this value will 
result in a more shallow depth map that may increase the chance of 
cloth vertices getting stuck in the cloth object. This attribute is located 
in the Extra Attributes section of the collision object’s shape node in 
the Attribute Editor.

Collision Display

This drop-down list only appears if you selected Cloth > Create 
Collision Offset/Depth Mesh for the collision object. Use this drop-
down list to control which collision object attributes are displayed as a 
mesh: Depth, Offset, Depth and Offset, or None.

Tip Neither Collision Offset nor Collision Depth is affected by 
the Solver Scale. For example, if Collision Offset is set to 1 
and Solver Scale is set to 10, the cloth will still be offset 1 
unit above the surface of the model.
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Control pinched cloth

Sometimes, cloth garments become pinched between two collision objects. 
For example, if you have a skirted character who sits down on a chair, you 
define the chair and the character skin as collision objects. If the chair and 
skin intersect, how is the cloth solved? Or if cloth gets caught under the 
arm and in between the elbows, how does the software handle the 
collisions?

The collision object triangle that is closer to the cloth in each time step 
takes precedence. The other collision object triangle is ignored by the cloth 
for that time step and is reconsidered the next time step. However, in 
some cases the proximity of the collision objects switches quickly. This can 
cause instability in the solution.

To help solve this problem, you can set the Collision Priority attribute so 
one collision object takes priority over another collision object during 
collisions. A lower value takes priority over a higher value. For example, 
in the case of the chair and the skirt, you could set the collision priority of 
the chair to 1, and collision priority of the character skin to 2. This would 
cause the vertices that are pinched to ignore the skin for those frames 
where both the skin and the chair were in contact. 

Paint cloth collision objects

Use the Paint Collision Properties Tool to paint collision properties of 
cloth objects. Specifically, the collision priority for collision objects is 
paintable as well as the collision depth map offset and collision offset 
map. These attributes are per-vertex maps and therefore cannot be painted 
on NURBS surfaces.

To make it easier to see the effects of your painting, you can also use  
Cloth > Create Collision Offset/Depth Mesh. The following are a couple 
of suggested workflows for using these features:

• ”To paint Cloth collision attributes” on page 47

• ”To tweak a Cloth collision simulation” on page 48

To paint Cloth collision attributes

1 Select the Cloth collision object to be painted.

2 In the Cloth menu set, select Cloth > Create Collision Offset/Depth 
Mesh.

A mesh appears around the collision object representing the Collision 
Offset value. To change the mesh display to Collision Depth, go to the 
Attribute Editor of the object’s shape node and in the Extra Attributes 
section, select depth from the Display Collision drop-down list.
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For more information, see ”Visualize cloth collision object attributes” 
on page 48.

3  Select Cloth > Paint Collision Properties Tool > .

The Paint Cloth Collision Properties Tool settings window appears.

4 Select the attribute you want to paint from the Paint Attribute drop-
down list and then select a Value to paint. For descriptions of these 
attributes, see see ”Cloth > Paint Collision Properties Tool” on 
page 60.

5 Set the rest of the painting attributes. See “Common Artisan Brush 
Tool Settings” in the Paint Effects, Artisan, and 3D Paint guide.

6 Drag to paint the collision object and see the effects on the Offset/
Depth mesh.

To tweak a Cloth collision simulation

If a Cloth collision simulation is incorrect and vertices are sticking inside 
the collision object, you can use the following workflow to adjust the 
simulation results.

1 Play the Cloth simulation.

2 Follow the steps in ”To paint Cloth collision attributes” on page 47 to 
paint Collision Depth or Collision Offset values in the problem areas.

3 To clear the Cloth cache, select Simulation > Delete Cache.

4 Replay the Cloth simulation.

5 Repeat steps 2 to 4 until the Cloth collision simulation is corrected.

Visualize cloth collision object attributes

You can visualize and animate a cloth object’s collision depth and offset 
attributes. This helps to better control the collision parameters.

Tips Paint in Smooth Shaded display mode. 

If painting Collision Depth, the mesh appears on 
the inside of the collision object. To make it easier to 
paint, go to the Attribute Editor of the collision 
object’s shape node, in the Extra Attributes section 
and adjust the overall Collision Depth value, for 
example, to -3. Once you’ve finished painting, reset 
the Collision Depth value. 
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To show the collision object’s offset or depth mesh

1 Select the collision object whose collision attributes you want to 
visualize.

2 Select Cloth > Create Collision Offset/Depth Mesh.

A mesh appears around the collision object. Also, a Collision Display 
drop-down list is added to the collision object attributes. Use this 
drop-down list to control which collision attribute is displayed: Depth, 
Offset, Depth and Offset, or None. For more information about 
collision attributes, see ”Adjust the cloth collision object” on page 44.

To hide the collision object’s offset or depth mesh

1 Select the collision object whose collision mesh you want to hide.

2 Select Cloth > Remove Collision Offset/Depth Mesh.

The mesh is removed from the collision object.

Simulate cloth

Once you have your cloth ready to drape over your character, you can 
start the simulation. The simulation is performed by the cloth solver, 
which assembles information on all the garments, cloth objects, the bodies 
they interact with, and any fields or constraints applied to the cloth.

You can use multiple solvers in your scene to segment the cloth 
simulations into multiple independent simulations that are solved 
separately (see ”Use multiple solvers in a scene” on page 120). 

What happens when cloth solves?

When you start the cloth simulation, a rubbery material is applied to the 
garment and it is not affected by gravity for the first few frames. This 
period is called the relax frame length. You can specify how long the relax 
frame length lasts (see ”Relax Frame Length” on page 40).

Collision object without mesh Collision object with mesh
Cloth

49



3 | Draping and fitting Cloth
How do I? > Use the cloth solver
This lets the simulation proceed more quickly to get past the state in 
which the cloth is stretched beyond its natural state and reach the point 
where it can solve more naturally. After a few frames, gravity affects the 
cloth and its normal material is applied. 

Once you’ve done the initial draping, you can save the initial state and set 
the relax frame length to 0.

Use the cloth solver

There are two ways for the cloth to solve:

• Play through the time slider 

• Start a local simulation 

For the draping phase, you get the same results using either method of 
cloth solving. 

Play through the time slider

When you play through the time slider, the cloth evaluates each time a 
frame advances. As time changes, the cloth’s motion is saved in a cache 
file so you can scrub in the time slider. 

To simulate by playing through the time slider

1 Make sure your start frame in the time slider is frame 1.

2 In your Animation preferences, make sure Playback Speed is set to 
Play every frame and Playback by is set to 1.

3 Click the play button. 

After a few seconds, your cloth should begin to drape over your 
character. 

4 To stop the simulation, press the Esc key or click the stop playback 
button. 

Important!

In interactive mode (GUI or non-batch mode), cloth 
simulation is triggered by refresh events, which can occur 
only when the 3D view is visible on the screen. If the Maya 
main window is iconified or if a screen saver is active, the 
simulation will stop. For background simulation done non-
interactively, we recommend you use batch mode.
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To undo a simulation created by playing through the time 
slider

1 Select Simulation > Delete Cache. 

For more information on caching, see ”Manage cache files” on 
page 98.

2 Click the Rewind button.

Start a local simulation

When you start a local simulation, the cloth solves but time does not 
advance and no cache is created. 

If you have an animated character, you can run a local simulation to drape 
the cloth without the character moving. You also use local simulation 
when using the drag control (see ”Use the Drag control” on page 55).

To run a local simulation

1 Select Simulation > Start Local Simulation.

2 To stop the simulation, press the Esc key or select Simulation > Stop 
Local Simulation.

To undo a local simulation

• Select Edit > Undo.

This returns you to the previous state of the cloth.

Modify the panel after simulating

You can change the resolution of a cloth garment, modify the shape of a 
panel, or add seams after you have run the simulation using the Fit to 
Surface option. The geometry is updated without having to start the 
simulation from the beginning.

When you use Fit to Surface, the cache is deleted and a new initial state is 
saved.

To modify the resolution

1 Select the cloth garment and display the cpStitcher attributes in the 
Attribute Editor.

2 Turn on Fit to Surface.

Tip You can tear off the Simulation menu so it is easier to select 
menu items. 
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3 Enter a new value for Base Resolution.

The cloth garment updates to the new resolution.

4 To stop the retessellation of your cloth, press the Esc key.

To modify the panel shape

1 Select Simulation > Disable Solver. 

2 Select the cloth garment and display the cpStitcher attributes in the 
Attribute Editor.

3 Turn on Fit to Surface.

4 Select some CVs and drag the curve to modify the panel shape.

5 Select Simulation > Enable Solver. 

The new topology is mapped onto the surface. 

6 Select Simulation > Start Local Simulation to run a local simulation.

You should see the modifications take shape.

To add a seam

1 Select the cloth garment and display the cpStitcher attributes in the 
Attribute Editor.

2 Turn on Fit to Surface.

3 Add the seam.

Important

Use caution when moving control points to make sure that 
all of the control points of the panel remain in a plane and 
that the curves of the panel continue to form a closed, non-
intersecting loop.

Low-resolution cloth High-resolution cloth
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Save initial state of the cloth

Once you have the cloth in the position you like, you save its initial state. 
This tells the cloth solver to use the current position as its start position.

To save the initial state

1 Select the cloth. 

2 Select Simulation > Save as Initial Cloth State. 

3 Select Simulation > Delete Cache. 

Adjust the cloth solver 

The cloth solver attributes affect how cloth solves in general. 

To adjust the solver attributes

1 Select the cloth and display the Attribute Editor. 

2 Click the cpSolver tab and set the desired attributes. For descriptions 
of these attributes, see ”cpSolver node” on page 38. 

See also ”Advanced solver performance tools” on page 117.

Solver hang detection

The solver can detect instances where it is having difficulties solving a 
simulation. To control how a solver reacts to situations where there is a 
probability of it hanging, use the following attributes to the cpSolver 
node: “Adaptation Control” and “monitorScript” in ”cpSolver node” on 
page 38.

Control cloth motion

You can use the velocity attributes to inhibit cloth motion when a garment 
is draped on a character that is stationary or barely moving. The velocity 
attributes control the velocity of cloth vertices when the velocity is close to 
zero.

Tips for setting velocity cutoff

Stopping cloth motion when a moving character stops

Set velocityCutoffMin to 1, velocityCutoffMax to 10, and 
velocityCutoffDamping to 4. 

Tip You can seam panels from a different garment. See ”Model 
parts of a garment” on page 34.
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With these velocity settings and a film frame rate of 1/24 fps, if your 
cloth vertices are moving less than 0.04 units per frame, the velocity 
will be set to zero. If the cloth vertices are moving between 0.04 and 
0.4, the velocity will be multiplied by 1/6. 

Reducing small popping of cloth vertices

Keyframe the Velocity Cutoff Min attribute from 0 to 2 during the 
frames where popping needs to be reduced. This helps correct 
popping without affecting the rest of the cloth animation. 

Set frame samples and time step size 

If your animation is moving fast and you notice that your cloth is 
penetrating the collision object or that the cloth motion is jerky, you can 
adjust the Frame Samples and Time Step Size. 

Frame Samples and Time Step Size work together to control how the 
solver works. Frame Samples is the number of times the solver samples 
the collision object geometry between successive frames. Time Step Size 
divided by Frame Samples is the maximum time, in seconds, that the 
internal dynamic solution advances. 

If you notice jerky motion or penetration, first try increasing the Frame 
Samples value. If that doesn’t fix the problem, decrease the Time Step in 
small increments. 

Scale the solver

If you are working in units smaller than real-world units, you can increase 
the Solver Scale attribute. This attribute lets you control the scale of the 
internal coordinate system of the solver.

When Solver Scale is set to 1.0 (the default), the solver coordinate system 
is the same as that used by Maya. When Solver Scale is set to 2.0, the 
solver coordinate system is two times larger than the one used by Maya. 

For example, if your 3D character is 6 inches tall in the Maya workspace 
but you want the clothes to look and behave as if your character is 5 feet 
(60 inches) tall, you can set the solver scale to 10.

solver scale = desired size / Maya size

10 = 60” / 6”

The solver scale doesn’t change the actual size of the cloth, it just makes 
the cloth behave as though it were a different size. To physically change 
the actual size of the cloth, you can change the U Scale and V Scale 
attributes of the property assigned to the panel (see ”U/V Scale” on 
page 74).
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Manipulate your cloth

You can manipulate your cloth several ways:

• You can manually move points on the cloth.

• You can use the Drag control to adjust areas of your cloth before you 
start animating. You can also use the Drag control as an animation 
tool.

• You can use constraints to attach objects to cloth or constrain cloth to a 
body (see ”Use cloth constraints” on page 79).

• You can apply dynamic forces to move the cloth (see ”Connect 
dynamic fields to your cloth” on page 91).

Manually move cloth points

Sometimes you need to move points around on your cloth to make it the 
exact shape you want. However, the solver doesn’t understand how to 
calculate the forces when you simply grab a point and move it. You need 
to re-evaluate the cloth in its modified position and calculate the 
appropriate forces.

To manually move cloth points

1 Click the right mouse button over the cloth and select Vertex.

2 Select some points on the cloth. 

3 Move the points to the desired location.

4 Select the cloth you just modified.

5 Select Simulation > Update Cloth State.

This gives the new cloth positions to the solver. It doesn’t delete the 
cache.

Use the Drag control

Sometimes you want to fix certain areas of your cloth before you start 
your animation. You can do this using a manipulator called a Drag control. 
You can also use the Drag control to roll up your character’s sleeves, pull 
a towel through a towel rack, or wrap a scarf around your character’s 
neck.

Tip You may want to use the proportional modification tool 
(Modify > Transformation Tools > Proportional 
Modification) because if the points move too far from each 
other, the cloth can become unstable.
Cloth

55



3 | Draping and fitting Cloth
How do I? > Manipulate your cloth
The Drag control takes points on your cloth and moves them along a path 
towards a destination. 

When you use the Drag control to fix certain areas of your cloth before 
starting your animation, you use a local simulation. When you use a local 
simulation, time does not advance in the time slider.

When you use the Drag manipulator as part of your animation, such as 
rolling up your character’s sleeves, you need to keyframe the Drag 
control.

To use the drag control

1 Click over the cloth poly mesh with the right mouse button and select 
Vertex.

2 Select a few vertices on the cloth. 

3 Select Simulation > Manipulators > Drag Control. 

A cloth manipulator is created, and the locator at the end of the path 
is selected. 

4 To manipulate the path, simply rotate or move the locator. 

5 To start simulating, select Simulation > Start Local Simulation. 

6 To stop the local simulation either press the Esc key or select 
Simulation > Stop Local Simulation.

To undo the effect of the drag control

Select Edit > Undo.

To keyframe the Drag control

1 Select the shuttle (small pyramid shape).

2 In the Channel Box, click shuttleShape and keyframe the U Value 
attribute. 
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To set the drag control attributes

1 Select the shuttle. 

2 In the Channel Box or Attribute Editor, enter values for the following:

U Value

Controls the position of the shuttle along the motion path. A value of 
0 is the start point and a value of 1 is the end point.

Rate

Controls the speed of the shuttle during local simulation. Typical 
values are 0.03 - 0.1.

To delete the drag control

In the Outliner, display the hierarchy of your cloth object. Select 
DragControl and delete it. 

Fix interpenetration problems

Sometimes you may see interpenetration between cloth and collision 
objects. Use the following tips to correct interpenetration.

• Keep the cloth mesh size reasonably small compared to the other 
objects for the final rendered simulation.

The cloth solver operates on the vertices of a cloth mesh, not the 
triangle edges. Because of this, if the size of the objects with which the 
cloth intersects is small compared to the size of the triangles of the 
cloth, the cloth edges may pass through those objects. Try increasing 
the resolution of the cloth.

• Avoid setting the initial state of the simulation with cloth bodies 
penetrating other objects in the simulation.

Drag control pulling cloth through ring

Shuttles
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The cloth solver tries to avoid any interpenetration between cloth 
bodies and other cloth and rigid bodies. 

• Raise the Frame Samples rate of the cloth solver.

This helps prevent collision objects from passing through the cloth. It 
also stabilizes high-speed cloth collisions with collision objects.

See ”Set frame samples and time step size” on page 54 for more 
information.

• Lower the Time Step attribute of the cloth solver.

This helps prevent collision objects from passing through the cloth. It 
also stabilizes high-speed cloth collisions with collision objects.

See ”Set frame samples and time step size” on page 54 for more 
information.

• Check the Collision Offset attribute of the collision object.

The Collision Offset specifies the distance the cloth stays from the 
collision object. See ”Applying properties to Cloth” on page 63 for 
more information.

Debug cloth collisions

Complex Cloth simulations that generate collision objects through the use 
of deformers or custom nodes can cause problems with the Cloth 
simulation when the object moves through the scene in an erratic or 
jumpy manner. If erratic motion occurs at the subframe level, you can use 
the Cloth Collision Debug feature to troubleshoot. See ”To debug a Cloth 
collision simulation” on page 59.

When you turn on Cloth Collision Debug and run the Cloth simulation, 
each collision object that was selected for debugging is displayed with a 
mesh. All of the generated meshes are parented under a common 
transform node called CollisionObjectDebug_solvername. Under this 
transform node, transforms are created for each subframe being 
evaluated. These nodes are named frame_frame_subframe. Under these 
transforms, the actual meshes are created and named after the original 
collision object that they are based on.

The Frame Samples attribute in the cpSolver node determines how many 
meshes are created for each frame of the simulation. 
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Large amounts of meshes may be created using this feature. Collision 
Object Debug Enable is keyable and you are encouraged to only turn it on 
for problematic areas. 

Once the simulation is run and the meshes are generated, they are visible, 
which may be confusing. To assist with visualizing all the meshes, there 
are control buttons in the cpSolver node in the Collision Object Debug 
section:

Show All, Hide All

Shows or hides all meshes.

First, Last, Previous, and Next

Use any of these to view the appropriate group of meshes and hide 
the previously viewed group (if any). First select Hide All (of the 
meshes) and then use these buttons to step through the subframes. 

To debug a Cloth collision simulation

1 Open the Cloth scene. 

2 Select the Cloth collision objects that seem to be causing the problem 
and then, in the Cloth menu set, select Cloth > Collision Object Debug 
> Add Selected Objects.

3 In the cpSolver node, go to the Collision Object Debug section and 
turn on the Collision Obj Debug Enable attribute.

4 Do one of the following:

• Select Simulation > Start Local Simulation to run the simulation.

• Use the Collision Object Debug controls that are available in the 
cpSolver node to visualize the results. 

The selected collision objects will be echoed as the solver evaluates 
them during simulation.

Note When using the Cloth Collision Debug feature, groups are 
created each time the Cloth solver samples the shape of a 
collision object. This may result in additional groups being 
created that are slightly beyond the playback range. If the 
collision geometry is not animated beyond the last frame of 
the playback, these additional groups will be in the same 
position as the last frame. This is expected behavior. 
However as a workaround you can delete the groups you 
don’t want. 
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Reference Cloth > Create Collision Object

Sets the selected object as a collision object. For more information, see 
”Create cloth collision objects” on page 43.

Cloth > Remove Collision Object

Removes the selected collision object from the solver. For more 
information, see ”Remove collision objects” on page 44.

Cloth > Create Collision Offset/Depth Mesh

Displays a collision mesh for the selected collision objects. See ”Visualize 
cloth collision object attributes” on page 48.

Cloth > Remove Collision Offset/Depth Mesh

Removes the collision mesh from the selected collision objects. See 
”Visualize cloth collision object attributes” on page 48.

Cloth > Paint Collision Properties Tool

Lets you use the Paint Collision Properties Tool to paint collision 
properties of cloth objects. For more information, see ”Paint cloth collision 
objects” on page 47. See also “How Artisan brush tools work” in the Paint 
Effects, Artisan, and 3D Paint guide.

Cloth > Paint Collision Properties Tool > 

Lets you specify the settings for the Paint Collision Properties Tool in the 
Tool Settings editor and then paint the selected Cloth collision object. In 
the Paint section there are some attributes unique to the Paint Collision 
Properties Tool. These unique attributes are described below. For 
descriptions of other attributes in the Paint section and attributes in all 
other sections, see “Common Artisan Brush Tool Settings” and also 
“Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 3D Paint 
guide.

Paint section

These are attributes in the Paint section that are unique to the Paint 
Collision Properties Tool.
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Reference > Simulation > Start Local Simulation
Select Attribute

Be sure to first select a Cloth collision object in the scene view, then 
select a cloth attribute from the drop-down list (see attribute 
descriptions below). When you paint, you paint values for that 
attribute.

Priority Map This is a per-vertex value [0,1]. These values are 
averaged over a face and added to Collision 
Priority. The resulting per-face values are used to 
resolve collisions on a per-face level in the same way 
that Collision Priority was used on the per-object 
level. 

Depth Map Offset This is a per-vertex value [-1,1]. These values are 
averaged over a face and then used as a percentage 
offset applied to the calculated depth at that face. 
This is used to adjust for situations where the depth 
map calculation method does not produce perfect 
results. The effective depth can be painted up or 
down as needed. 

If Depth Map Offset exists and Depth Map Enable is 
not turned on, Depth Map Offset is instead applied 
to Collision Depth. This allows the depth map to be 
completely manually painted if that is desirable. 

Collision Offset Map This is a per-vertex value [-1,1]. These values are 
averaged over a face and then used as a percentage 
offset applied to the calculated offset at that face. 
This is used to adjust for situations where the depth 
offset calculation method does not produce perfect 
results. The effective offset can be painted up or 
down as needed. 

Delete Attribute

If you’ve painted an attribute and want to undo the painting, select 
this attribute from the Delete Attribute drop-down list.

Simulation > Start Local Simulation

This starts the Cloth simulation. For more information, see ”Simulate 
cloth” on page 49 and ”Start a local simulation” on page 51.

Simulation > Stop Local Simulation

This stops the simulation that’s running. For more information, see ”Start 
a local simulation” on page 51.
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Simulation > Save as Initial Cloth State

Use this to tell the cloth solver to use the current position as its start 
position. For more information, see ”Save initial state of the cloth” on 
page 53.

Simulation > Update Cloth State

Use this to give the new cloth positions to the solver, but it doesn’t delete 
the cache. For more information, see ”Manually move cloth points” on 
page 55.

Simulation > Manipulators > Drag Control

Activates the Drag Control Cloth manipulator and the locator at the end 
of the path is selected. For more information, see ”Manipulate your cloth” 
on page 55 and ”Use the Drag control” on page 55.
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About Applying properties to cloth

Cloth properties work much like shaders. However, instead of assigning a 
color or texture like a shader, cloth properties specify the physical 
properties of the cloth. These properties affect how the cloth behaves 
when it moves. For example, you could create a property that makes your 
cloth behave like denim. See ”Apply properties to panels” on page 63.

You can create new materials and save them in your own material library.

You can also paint properties on portions of the cloth panel instead of the 
entire panel. See ”Paint properties on cloth” on page 64.

How do I? Apply properties to panels

By default, each panel is connected to a property called cpDefaultProperty. 
However, you can add as many properties as you want and connect any 
panel to any property.

To create a new property

• Select Simulation > Properties > Create Cloth Property. 

This creates a new property. If you have any panels selected, the 
property is automatically connected to the panels. 
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To assign a property to a panel

1 Select the panel.

2 Select Simulation > Properties > cpPropertynumber. 

The property is assigned to the selected panels. 

To change attributes of the property

1 Do one of the following:

• Select Simulation > Properties > cpPropertynumber >  to display 
the Attribute Editor.

• Select the panel and look in the Channel Box for the attributes.

2 Enter values for the attributes in the Property Attributes section. For 
descriptions of these attributes, see ”cpProperty node” on page 73. 

Remove Cloth properties

Use Remove Cloth Property to sever the connection between the cloth and 
the solver. The Cloth Property node remains in the Properties submenu.

To remove a cloth property

1 In the Cloth menu set select Simulation > Properties > PropertyName, 
where PropertyName is the name of the desired property.

2 Select Simulation > Properties > Remove Cloth Property. This 
removes the selected cloth property.

Paint properties on cloth 

You can use the Paint Cloth Properties Tool to paint properties, such as 
wrinkling effects across the entire surface of a garment or cloth object, and 
tessellation of garments and panels. This lets you apply properties to 
portions of the cloth instead of the entire panel or object. You could also 
use the Paint Cloth Properties Tool to apply properties such as stiffness to 
isolated parts of the garment rather than to whole panels, much like 
spraying starch on a collar. 

When you select a property attribute to paint, a paint attribute is 
dynamically added to the cloth. The paint attribute is used as a multiplier 
or “weight.” The property attribute value is multiplied by the paint 
attribute value. 

To paint properties on cloth

1 Select Shading > Smooth Shade Selected Items.

2 Select the cloth you want to paint property attribute values on.
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3 From the Cloth menu set, select Simulation > Properties > Paint Cloth 
Properties Tool > .

The Tool Settings window opens. For information about these 
settings, see ”Simulation > Properties > Paint Cloth Properties Tool” 
on page 73.

4 From the Paint Attribute drop-down menu, select the property 
attribute you want to paint values for. If you want to paint wrinkles, 
select the bendAngle attribute. (See ”Attribute for painting wrinkles” 
on page 65.) If you want to paint tessellation, paint the tessellation 
attribute. (See ”Attribute for painting tessellation on garments and 
panels” on page 67.)

For information on the property attributes see ”Apply properties to 
panels” on page 63.

5 Define the Paint Cloth Properties Tool settings, if required. 

For each property attribute, the initial value is set to 1.0. For 
information on defining settings, see ”Simulation > Properties > Paint 
Cloth Properties Tool” on page 73.

6 Move the pointer over the cloth.

The pointer becomes a paintbrush.

7 Paint over the triangle edges.

The value of the property attribute in the painted area is modified 
according to the settings of the Paint Cloth Properties Tool. Look in 
the Script Editor to see the values.

Painting U/V attributes

For attributes with U and V settings, such as U Scale, V Scale, U BendRate 
and V BendRate, the U and V share one paint attribute. 

For example, if you select the Scale property from the Paint Attribute 
pulldown, U Scale and V Scale are both affected by the Scale weight. The 
formula is:

the final uscale = uscale * scaleWeight
the final vscale = vscale * scaleWeight

Attribute for painting wrinkles

Cloth has an attribute—bendAngle—to make it easy to paint wrinkles on 
your cloth. The bendAngle attribute is dynamically added to the cloth 
when you choose bendAngle from the Paint Cloth Properties Tool. 
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The bendAngle attribute specifies the resting angle of the cloth. Initially, 
the resting angle value for each edge of each triangle of the cloth mesh is 
zero.The cloth solver uses the bendAngle to bend the cloth mesh about the 
each triangle edge. When painting, you can see the final values for each 
vertex in the Script Editor.

For example, in the image below notice the wrinkles on the cloth sheet. 
 

If you want to see a larger wrinkle propagated along the diagonal, you 
can use the Paint Cloth Properties Tool to paint a bendAngle value on this 
area. 
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After the area is touched up, you simulate the cloth. The bendAngle 
attribute causes the cloth to bend or wrinkle in this region during the 
simulation. 

Attribute for painting tessellation on garments and 
panels 

Using the paintable attribute, tessellation, you can control the number of 
triangles on Cloth garments and panels. This does not work for Cloth 
objects.

In production, the Cloth tessellation is bumped to very fine to catch 
details in certain areas, allowing the tessellation to be very coarse in areas 
where you don't care or expect these details. The total number of triangles 
can be reduced to several times less and the overall performance and 
memory consumption also improve accordingly. Once tessellation is 
selected, click the Apply Tessellation button to get the new tessellation 
result.

Tessellation ranges in [0,1] as other paintable attributes and it's used to 
reduce the tessellation. In general, you would set the max tessellation in 
the panel node or stitch node, and then use tessellation to reduce the 
tessellation.

Change the Cloth Properties Paint Tools settings

You can change the Cloth Properties Paint Tool settings to create different 
effects. Again, these are the same as the Artisan brush tool settings. See 
the following topics in the Paint Effects, Artisan, and 3D Paint guide:
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How Artisan brush tools work

Artisan Brush Tool Settings

Common Artisan Brush Tool Settings

Set cloth per-vertex properties without using Artisan 
tools

You can set cloth properties on a per vertex basis without using Artisan 
tools. To do this you must first add the attribute, as follows:

addAttr -ln attribute_name -dt doubleArray

Then you can set the value of the attribute using the setAttr command. For 
example:

1 You should add an attribute to Shape node, such as:

select -r clothShape1
addAttr -ln (/attribute_name/ + "Weights") -dt 
doubleArray;

2 You will have to suffix "Weights" with the attribute name.

3 Build a double array of the size of Cloth and use setAttr on it.

More specifically:

select -r clothShape1
addAttr -ln "bendResistanceWeights" -dt doubleArray;
setAttr clothShape1.bendResistanceWeights -type doubleArray 
10 0 1 0 1 0 1 0 1 0 1;

Vertex level cloth properties

You can assign cloth properties to sets of vertices on a cloth object. Keep 
the following things in mind when assigning cloth properties to sets of 
vertices:

• This works for cloth objects only, therefore you can’t add vertex 
property sets to panels. 

• You can’t assign vertices to a property that is already assigned to the 
entire cloth object. Instead, first remove the property from the cloth 
object and then reassign it as a set.

To create a cloth property for a set of vertices

1 Select the desired vertices.

2 In the Cloth menu set, select Simulation > Properties > Create Cloth 
Property.
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The selected vertices are automatically assigned to the new property 
and the cpProperty node is displayed in the Attribute Editor. For 
more information about cpProperty attributes, see ”cpProperty node” 
on page 73.

3 Optionally, you can change the Orientation value. The Orientation 
attribute controls the direction the indicator is facing that’s displayed 
on each vertex that’s part of the Cloth Property. This is to help 
distinguish between vertex property sets.

To add vertices to an existing property

1 Select the vertices on the cloth object you want to add.

2 Do one of the following:

• Select Simulation > Properties > PropertyName, where 
PropertyName is the name of the desired property.

• Go to the cpProperty node and in the Set List section, click the 
Add selected vertices to set button.

The vertices are added to the set.

To remove vertices from a property

1 Select the vertices on the cloth object you want to remove.

2 Go to the cpProperty node and in the Set List section, click the Remove 
selected vertices from set button.

To replace all vertices in a property

1 Select the vertices on the cloth object you want to be in the set.

2 Go to the cpProperty node and in the Set List section, click the Replace 
set with selected vertices button.

Use the material library

You can create new materials and save them in your own material library. 
You can also rename or delete materials from the library. 

A material is defined by the settings of the property attributes. The 
material library is stored in your userPrefs.mel file. 

Indicators displayed on each 
vertex in the Cloth Property
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The materials are used as presets. You assign a material to a property and 
the property values are set to the presets defined by that material. You can 
then assign that property to a panel. 

The library also comes with pre-made materials. You cannot modify or 
remove a pre-made material, but you can copy one and modify the copy 
as you wish.

To create a material and save it in the material library

1 Select Simulation > Properties > Create Cloth Property. 

This creates a new property node. If you have any panels selected, the 
property is automatically connected to the panel. 

2 Select Simulation > Properties > cpPropertynumber > .

The property node attributes are displayed in the Attribute Editor.

3 Set the values of the property attributes.

4 Scroll down and display the Material Library section of the Attribute 
Editor. 

5 Click the Save As button and enter a name for the material in the 
dialog box. Click OK to save the material.

The material is saved in your userPrefs.mel file.

To assign a material from the library

1 Load a property node into the Attribute Editor by selecting Simulation 
> Properties > cpPropertynumber > .

You can either use an existing Property node or create a new property 
node.

2 Scroll down and display the Material Library section of the Attribute 
Editor. 

3 Click the folder button next to the Material Name box. 

4 From the list, select the material you want to use. 

5 Click OK. 

6 Select the panel or panels that you want to assign the material to.

Tip You can share materials in your material library with others 
by assigning the material to a property node and exporting 
the property node. See ”To export a material from the 
material library” on page 71.
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7 Assign the Property node to the panel by selecting Simulation > 
Properties > cpPropertynumber (selecting the property node to which 
you assigned the material).

To edit a material in the library

1 Load a property node into the Attribute Editor by selecting 
Simulation > Properties > cpPropertynumber > .

2 Scroll down and display the Material Library section of the Attribute 
Editor. 

3 Click the folder button next to the Material Name box. 

4 From the list, select the material you want to edit and click OK. 

5 Modify the property attributes and click Update.

To rename a material in the library

1 Load a property node into the Attribute Editor by selecting 
Simulation > Properties > cpPropertynumber > .

2 Scroll down and display the Material Library section of the Attribute 
Editor. 

3 Click the folder button next to the Material Name box. 

4 From the list, select the material you want to rename and click OK.

5 Click the Rename button in the Attribute Editor.

6 Enter a new name in the dialog box and click OK.

To remove a material from the library

1 Load a property node into the Attribute Editor by selecting 
Simulation > Properties > cpPropertynumber > .

2 Scroll down and display the Material Library section of the Attribute 
Editor. 

3 Click the Remove button. 

4 From the list, select the material you want to remove and click 
Remove.

To export a material from the material library

1 Select Simulation > Properties > New. 

This creates a new property node.

2 Load the new property node into the Attribute Editor by selecting 
Simulation > Properties > cpPropertynumber > .

3 Scroll down and display the Material Library section of the Attribute 
Editor. 
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4 Click the folder button next to the Material Name box. 

5 From the list, select the material you want to export and click OK. 

6 With the new property node selected, select File > Export Selection.

7 Assign a name to the scene with the exported property node.

Other users can now import the scene and save the material to their 
userPrefs.mel file.

To import a material into your material library

1 Import the scene that has the material.

2 Select the property node that has the material assigned to it.

3 Display the Attribute Editor and open the Material Library section.

4 Click Save As.

5 Enter a name and click OK.

The material is now part of your Material Library and will be saved to 
your userPrefs.mel file. You can delete the imported property node, it 
you want.

Sample properties for cloth

We’ve included some scenes with sample properties to help you in 
creating properties for your garments. The extras/cloth/properties 
directory provides a web page with examples of various cloth property 
settings and scenes that show example properties.

Reference Simulation > Properties > Create Cloth 
Property

Use this to create a new property (attached to the selected panels). For 
more information, see ”Apply properties to panels” on page 63.

Simulation > Properties > Remove Cloth 
Property

Use this to sever the connection between the cloth and the solver. The 
Cloth Property node remains in the Properties submenu. For more 
information, see ”Remove Cloth properties” on page 64.
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Simulation > Properties > Paint Cloth 
Properties Tool

Lets you use the Paint Cloth Properties Tool to paint properties and 
wrinkling effects across the entire surface of a garment. For more 
information, see ”Paint properties on cloth” on page 64. See also “Using 
Artisan brush tools” in the Paint Effects, Artisan, and 3D Paint guide.

Simulation > Properties > Paint Cloth Properties Tool 
> 

Lets you specify the settings for the Paint Cloth Properties Tool in the Tool 
Settings editor. In the Paint section there are some attributes unique to the 
Paint Cloth Properties Tool. These unique attributes are described below. 
For descriptions of other attributes in the Paint section and attributes in all 
other sections, see “Common Artisan Brush Tool Settings” and also 
“Artisan Brush Tool Settings” in the Paint Effects, Artisan, and 3D Paint 
guide.

Paint section

These are attributes in the Paint section that are unique to the Paint Cloth 
Properties Tool.

Select Attribute

Select a cloth attribute from the drop-down list. When you paint, you 
paint values for that attribute.

Apply Tessellation

Click this button if you’ve painted the tessellation attribute and want to 
see the new tessellation. 

Delete Attribute

If you’ve painted an attribute and want to undo the painting, select 
this attribute from the Delete Attribute drop-down list.

cpProperty node

These are the attributes in the cpProperty node.(Simulation > Properties > 
cpProperty > ) For more information, see ”Apply properties to panels” 
on page 63 and ”Vertex level cloth properties” on page 68.

Property Attributes

These are the attributes in the Property Attributes section of the 
cpProperty node. 
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The slider ranges for the Property Attributes represent values for 
realistic cloth. To enter values that exceed the default slider range 
(and create unrealistic cloth effects), type them in the boxes or Ctrl-
drag in the boxes to use the virtual sliders.

U/V Bend Resistance

Controls how much the cloth resists bending in the U and V 
directions. The greater the U/V Bend Resistance value, the stiffer the 
cloth. Lower values create very flexible cloth. The default is 10.

U/V Bend Rate

The U/V Bend Resistance may increase non-linearly as the cloth 
triangles are folded from 0 degrees to 180 degrees. The U/V Bend 
Rate attribute controls the exponent of how much the U/V Bend 
Resistance increases from 0 to 180 degrees.

A U/V Bend Rate of 0 means a constant resistance. A U/V Bend Rate 
of 1 means that at 180 degrees, the bending resistance is so high that it 
will not bend without a huge amount of force. The default is 0.

U/V Stretch Resistance

Controls how much the cloth resists stretching in the U and V 
directions. The greater the value, the more the cloth resists stretching. 
A value of 100 is very stiff cloth and a value of 1 is very stretchy. The 
default is 50. A value greater than 0 is recommended. 

Shear Resistance

Controls how much individual triangles resist moving in an opposite 
but parallel sliding motion. The higher the number, the less the 
triangles can shear. The default is 45. A value greater than 0 is 
recommended.

U/V Scale

Controls the scale of the cloth in the U and V directions. 

Values of 2 in the U and V Scale make the cloth object twice its actual 
size. Values of 0.5 in the U and V Scale make the panel half its actual 
the size. The default is 1.

Density

Controls the mass per unit area of the cloth. The greater the value, the 
more mass per unit area of the cloth. A value of 0.1 creates a very 
heavy cloth; a value of 0.01 creates a light cloth. The default is 0.01.
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Thickness

Controls the depth dimension of the cloth. The value specifies the 
collision offset of the cloth when it collides with itself and with other 
cloth bodies. The amount of offset may vary depending on the 
Thickness Force attribute. The default is 0.2. The recommended range 
for thickness is between 0.1 and 0.7. 

Thickness is measured in centimeters and scaled by the solver scale 
attribute. If you increase the Solver Scale value, Thickness is 
decreased. For example, if solver scale is 10 and thickness is 0.2, then 
the actual thickness resulting will be 0.02 centimeters for your cloth 
mesh. If you choose thickness values beyond the recommended range, 
the simulation results are unpredictable.

When you have two cloth bodies colliding, the Thickness attribute is 
not additive. The solver uses the greater value as the Thickness. For 
example, if one cloth body has a Thickness of 0.5 and the other has a 
Thickness of 0.2, the distance maintained between them when they 
collide is 0.5, not 0.7.

Thickness Force

Controls the force used to maintain the collision offset specified by the 
Thickness attribute during cloth-to-cloth collisions. If a heavy piece of 
cloth gets closer to another piece of cloth than the distance specified 
by the Thickness attribute, you can increase this value to keep the 
heavier cloth at the proper distance. The default is 1.0. 

In scenes with many cloth-to-cloth collisions, the recommended range 
for thickness force is between 30 and 75. A value of 50 for some 
animations is ideal. 

Cloth Friction

Controls friction between the cloth and other cloth bodies. You can 
enter values between 0 and 1. Smaller values create less friction. The 
default is 0.3.

Cloth Damping

Specifies how strongly the overall motion of the cloth is diminished. 
The default is 0.2, which adds stability to the system. A value greater 
than 0 is recommended.

Air Damping

Specifies how strongly the motion of the cloth is diminished by the 
physical properties of the air. Air damping provides air resistance to 
triangles that are normal to the direction of travel. If the triangles on 
the cloth are parallel to the direction of travel, Air Damping has no 
effect. The default is 0.1.
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Static Friction

Determines the friction between cloth and collision objects that are at 
rest and in contact. Static friction must be overcome for the cloth 
object to move against collision objects. 

A value of 0 lets the cloth move freely against a collision object. A 
value of 1 restricts the movement between cloth and collision objects. 
The default is 0.6. 

Dynamic Friction

Sets the amount of resistance to the motion of a moving cloth object 
against collision objects. A value of 0 lets the cloth move freely against 
a collision object. A value of 1 restricts the movement between cloth 
and collision objects. The default is 0.1.

Blend Weights

In the Blend Weights section, use the slider to set a blend weight value for 
vertices that overlap with other sets. The blend weight value can be 
between 0 and zero means the set has no weight, and 1 means the set has 
full weight. For example, if two overlapping sets both had a blend weight 
of 1, then the sets property values would be averaged together. But if set 
A had a blend weight of 0.5 and set B had a blend weight of 1.0, then set A 
would get half the weight of set B.

Set List

If the property contains a set of vertices the following buttons are 
available in the Set List section of the cpProperty node.

Select set vertices

This selects the vertices on the cloth object. 

Add selected vertices to set

This adds the selected vertices to the set of vertices in the cloth 
property.

Replace set with selected vertices

This replaces the set of vertices in the cloth property with the 
currently selected vertices.

Remove selected vertices from set

This removes the selected vertices from the set of vertices in the cloth 
property.
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About Animating cloth

When you animate your character, the cloth solver calculates the collisions 
and motion of the cloth. Before you begin animating your character, you 
need to move the character from the dress-up pose to the animation start 
pose. If want to drape the garment about the character in a particular way, 
you can use the drag control to adjust the garment (see ”Use the Drag 
control” on page 55). 

To modify the movement of the cloth during the animation, you can add 
constraints or fields from Maya Dynamics. 

Related topics

”Create the animation start pose for cloth” on page 77

”Use cloth constraints” on page 79

”Connect dynamic fields to your cloth” on page 91

”Constraint Shape node” on page 92

”Collision Shape node” on page 93

”Point Assigner node” on page 94

How do I? Create the animation start pose for cloth

To create the animation start pose, you move your character from the 
dress-up pose to the position it will be in at the start of the animation. You 
may want to add some frames to the start of your scene to accommodate 
this transition.
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To create the animation start pose

1 Place your character in the dress-up pose at a frame that precedes 
your animation.

2 Save a keyframe.

For example, if your animation starts at frame 1, place your character 
in the dress-up pose at frame -20.

3 Go to the first frame of your animation.

4 Position your character in its animation start pose.

5 Save a keyframe.

Dress-up pose Animation start pose
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Use cloth constraints 

Creating clothes for character animation 
involves more than creating panels and 
seaming them together. Sometimes you may 
want to constrain certain parts of your 
clothing to your character so it doesn’t fall 
off. You can do this using constraints. For 
example, you can use constraints to make 
sure the pants of your character stay on, or to 
keep straps in a dress attached to the 
shoulders.

In addition, you can use constraints to pin 
clothing together or attach items such as 
buttons or pockets.

Cloth includes the following constraint types:

• transform constraints

• mesh constraints

• cloth constraints

• button constraints

• collision constraints

• field constraints

Constrain points or curves

You can attach constraints to points on the cloth or to a panel curve. When 
you constrain points, Cloth creates a point assigner, which determines the 
actual set of vertices that are constrained as the resolution of the cloth 
changes. See ”Edit the point assigner” on page 89. 

When you constrain a panel curve, Cloth creates a curve assigner, which 
lets you determine the start and end vertices that are constrained along 
the curve. See ”Edit the curve assigner” on page 90.

Create transform constraints

One way of manipulating your cloth during an animation is to use a 
transform constraint. A transform constraint constrains the cloth to the 
object at a certain distance, as though it were welded. If the object moves, 
the points on the cloth that are constrained also move.

You can constrain the cloth to a locator or to anything with a transform. In 
Maya, a transform can be the parent of a shape, a joint, or a parent of 
other transforms.
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If you scale or rotate the transform, the transform constraint scales or 
rotates the constrained points. This is a quick way to deform a set of cloth 
points. 

You constrain cloth by selecting either cloth points or panel curves.

To create a transform constraint

1 Select Create > Create Locator or create the object to which you want 
to constrain the cloth.

2 Position the locator or object near your cloth where you want to use 
the Transform Constraint. Keep it selected.

The distance you place the locator or object from the cloth vertices will 
be maintained by the constraint during the simulation.

3 Do one of the following:

• If you are constraining cloth points, click the right mouse button 
over the cloth mesh and select Vertex. Shift-Ctrl-click the vertex 
points you want to constrain.

• If you are constraining a panel curve, Shift-Ctrl-click the curve 
you want to constrain. 

When you move the locator or object, these vertex points or the curve 
will move with it exactly during the simulation (this includes rotating 
and scaling the locator). 

Transform constraint: 
cloth points to locator

Transform constraint: 
panel curve to locator

Transform constraint: panel 
curve to scaled locator

Tip If the cloth has already been simulated, the panel curve 
may not be located near the cloth edge to which it belongs. 
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4 With the vertex points and the locator or object transform selected, 
choose Constraints > Transform. 

The points do not snap to the constraint; they remain at a fixed 
distance from the target and at a fixed orientation relative to the 
target.

5 Now you can animate the locator and the vertex points will move 
with it. 

 To adjust transform constraint attributes

1 Select the constraint. 

2 In the Attribute Editor or Channel Box, set the desired attributes in the 
ConstraintShape tab. For descriptions of these attributes, see 
”Constraint Shape node” on page 92.

To delete the transform constraint

1 Do one of the following:

• Select the constraint in the view and delete it.

• In the Outliner, open the cloth transform so you can see the 
shapes below them. Select transformConstraint and delete it. 

Create mesh constraints

Sometimes you may want to constrain certain parts of your clothing to 
your character so the clothing doesn’t fall away. This can be useful to 
make sure the pants of your character stay on, or to keep straps in a dress 
attached to the shoulders. A mesh constraint constrains cloth to a collision 
object.

The Is Soft attribute, when turned on, constrains cloth to a collision object 
via springs. The amount of elasticity of the springs is controlled by the 
Stiffness and Damping attributes, which are also paintable per-vertex.

To add mesh constraints to a character constructed from multiple collision 
objects, see ”Use mesh constraints with multiple collision objects” on 
page 82.

To create a mesh constraint

1 Do one of the following:

• To constrain cloth vertices to a collision object, click the right 
mouse button over the cloth and select Vertex. Select the vertices 
in the cloth you want to constrain. 

• To constrain a panel curve to a collision object, select the curve.
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2 Shift-Ctrl-click the collision object to which you want to constrain the 
cloth.

3 Select Constraints > Mesh. 

To adjust mesh constraint attributes

1 Select the constraint. 

2 In the Attribute Editor or Channel Box, set the attributes Constraint 
Weight and Size in the MeshConstraintShape tab. For descriptions of 
these attributes, see ”Constraint Shape node” on page 92.

To delete the mesh constraint

1 Do one of the following:

• Select the constraint in the view and delete it.

• In the Outliner, open the cloth transform so you can see the 
shapes below it. Select meshConstraint and delete it. 

Use mesh constraints with multiple collision objects 

If your character is constructed from multiple collision objects, you can 
save time by selecting a group of collision objects to use with mesh 
constraints.

To create a mesh constraint with multiple collision objects

1 Select the collision objects for the character. Select Edit > Group to 
group the collision objects under one transform. 

2 Right-click over the cloth and select Vertex from the popup menu. 

3 Select the cloth vertices you want to constrain.

4 Do one of the following:

• Shift-select one of the collision objects in the group. Press the up 
arrow to select the group’s transform.

• In the Outliner, Ctrl-click the group transform.

5 Select Constraints > Mesh. 

Each selected cloth vertex is constrained to the closest collision object. 
One or more mesh constraints is created. 

Create cloth constraints 

 A cloth constraint binds cloth vertices to cloth. When you create a cloth 
constraint, the vertices on the source cloth are bound to triangles on the 
target cloth. Even as the target cloth is deforming and moving, the vertex 
holds its position relative to that assigned triangle.
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You do not need to select the individual 
triangles. The cloth constraint detects the 
location of the source and target, finds 
the closest triangle, and binds them 
together.

You can use a cloth constraint to lay one 
cloth on top of another cloth. For 
example, you can design a pocket as a 
small separate piece of cloth and 
constrain it to a shirt using a cloth 
constraint. You use the Offset attribute to 
control which side of the cloth the pocket 
is constrained to and how far the source cloth lies from the target cloth.

If you position the source cloth near the target cloth and the offset is 0, 
when the constraint is simulated, it pulls the source cloth into the target 
cloth. 

You can also animate stiffness and damping attributes. The cloth 
constraint use springs internally to keep the cloth sewn together. You can 
use a high stiffness value to keep the cloth adjacent.

When the Stitch attribute is turned on, the Offset, Damping and Stiffness 
attributes are all disabled so they have no effect. In “Stitch mode” 
constrained cloth vertices are kept very close (0.1 mm away) to the closest 
point on the target. This has the same effect that a user setting the offset to 
0 would desire; however, an offset of zero will still result in a gap between 
the cloth vertices and the target because the solver considers the cloth to 
have thickness. This is useful for doing things like attaching a collar to a 
shirt when modeling clothing with cloth objects.

You can make cloth constraints only with cloth made from panels, not 
with cloth objects made from polygonal geometry.

To create a cloth constraint between garments

1 Do one of the following:

• To constrain the vertices of one cloth garment to another cloth 
garment, right-click over the source cloth and select Vertex. Select 
the vertices in the cloth you want to constrain. 

• To constrain a panel curve to a cloth, select the curve.

2 Shift-Ctrl-click the target cloth.

3 Select Constraints > Cloth.

You can create a pocket
using a cloth constraint
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Constrain cloth to itself

In addition to creating cloth constraints between 
separate pieces of cloth, you can constrain a piece of 
cloth to itself. For example, you can create a vest with 
a left front panel and a right front panel and 
constrain the left front to the right front. 

When you constrain one piece of cloth to another 
piece of cloth, you specify the cloth points or curve to 
be constrained, and the target object. When you 
constrain cloth to itself, you specify the points or 
curves on the cloth to be constrained. The software 
determines the closest target points on the cloth.

To create a cloth constraint within a garment

1 Select the cloth points or curve you want to constrain.

2 Select Constraints > Cloth.

Cloth determines the target for the constraint. The software looks for 
the closest points that are greater than three edge lengths away from 
the selected points. When you play the simulation, the points or curve 
you selected will be constrained to that target.

To adjust cloth constraint attributes

1 Select the constraint. 

2 In the Attribute Editor or Channel Box, set the attributes in the 
ClothConstraint Shape tab. For descriptions of these attributes, see 
”Constraint Shape node” on page 92.

To delete the cloth constraint

1 Do one of the following:

• Select the constraint in the view and delete it.

• Select the cloth and in the Outliner, turn on Show > Shapes. Open 
the cloth transform so you can see the shapes below it. Select 
clothConstraint and delete it. 

Create button constraints

A button constraint follows the cloth, like a tracking device. It can be 
positioned anywhere on the cloth—on a vertex or in the middle of a 
triangle. 

Cloth constrained
 to itself
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When you create a button constraint, a transform is created and updated 
every frame, which tracks the position and orientation of the cloth. You 
can parent an object to the transform and it will follow cloth like a button 
does.

The button transforms are parented under the cloth’s transform. 

Types of button constraints

You can create a button constraint three ways:

• You can position the button exactly where you want it to be, even if it 
is offset from the cloth.

• You can snap the button to the surface of the cloth.

If you want to move the button, you can select it and translate, rotate, 
or scale it. Even if you snap to the surface of the cloth, you can later 
make the button offset or rotated from the cloth.

• You can rotate the button 90 degrees in the X axis when you create it.

Because most buttons are modeled in object space with the Y axis 
pointed up, this method rotates the button so that the Y axis is in line 
with the Z axis of the cloth.

Tip You can select multiple objects and make them into buttons. 
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To create a button constraint and preserve its position
 

1 Create the geometry for the button.

2 Position the geometry exactly where 
you want the button to be on the cloth.

3 With the button geometry still selected, 
Shift-Ctrl-click the cloth.

4  Select Constraints > Button > .

5 In the Button Constraint Options 
window, turn on Preserve Translation 
and Preserve Rotation.

This preserves the position and offset of 
the button in world space. The button 
does not move after the constraint is 
created.

To create a button constraint and snap it to cloth

1 Create the geometry for the button.

2 Position the geometry approximately above 
the surface of the cloth. 

You do not need to orient it exactly. The 
constraint will re-orient it.

3 With the button geometry still selected, Shift-
Ctrl-click the cloth.

4 Select Constraints > Button > .

5 In the Button Constraint Options window, 
turn off Preserve Translation and Preserve 
Rotation.

6 Set Translate x, y, z and Rotate x, y, z to 0, 0, 
0.

Button constraint with original 
position preserved

Button constraint 
snapped to cloth
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To create a button constraint and rotate 
it 900

1 Create the geometry for the button.

2 Position the geometry or locator 
approximately above the surface of the cloth. 

You do not need to orient it exactly. The 
constraint will re-orient it.

3 With the button geometry still selected, 
Shift-Ctrl-click the cloth.

4 Select Constraints > Button > .

5 In the Button Constraint Options window, 
turn off Preserve Translation and Preserve 
Rotation.

6 Set Rotate x, y, z to 90, 0, 0.

To select a button constraint

1 Do one of the following:

• Select the button and press the up arrow key to select the button 
constraint.

• In the Outliner, open the cloth transform that the button is 
attached to so you can see the transforms below it. Select 
cpButton. 

To move a button constraint

1 Select the button constraint.

2 In the Channel Box, click the U Coord or V Coord label.

3 Move the pointer into the view and middle-mouse-drag to move the 
button.

To delete a button and button constraint

1 Select the button geometry in the view.

2 Press the up arrow key.

The cpButtonnumber object is selected.

3 Press the Backspace key to delete the button and the button constraint.

To delete a button constraint without deleting the button

1 Select the button geometry in the view. 

2 In the Outliner, press the right mouse button and select Show selected. 

Button constraint snapped 

to cloth and rotated 900
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3 In the Outliner, use the middle mouse to drag the highlighted shape 
and drop it so it is unparented.

4 In the Outliner, select cpButtonnumber and press the Backspace key to 
delete the button constraint.

Create collision constraints

Collision constraints let you control collisions on a per-vertex basis and 
animate the control over time.

When you create a collision constraint, you can select cloth vertices or 
panel curves and disable the cloth-to-cloth collisions and cloth-to-collision 
object collisions on those vertices. This can help untangle cloth in many 
cases.

To create a collision constraint

1 Do one of the following:

• To constrain cloth vertices, click the right mouse button over the 
cloth and select Vertex. Select the vertices in the cloth you want to 
constrain. 

• To constrain a panel curve, select the curve.

2 Select Constraints > Collision. 

A collision constraint is created.

3 You can set the attributes in the Channel Box or Attribute Editor in the 
CollisionShape tab. For descriptions of these attributes, see ”Collision 
Shape node” on page 93.

Tips for displaying and selecting constraints

 Each point that is currently constrained 
or affected by the constraint is displayed 
as a square. You can increase the Size 
attribute to make it easier to select the 
constraint.

To select a constraint

1 Do one of the following:

• Select the constraint. If you have 
selected the constraint and the cloth 
mesh, hold down the CTRL key and 
click the cloth mesh.

This deselects the cloth mesh so just the constraint is selected.

• Click  to turn off the Surfaces pick mask and select the constraint.

Constraint
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To change the size of the constraint

1 Select the constraint.

2 In the Channel Box, increase the Size value.

Edit constraints

You can edit membership of Cloth constraints using the Edit Constraint 
Membership Tool.

To edit the set membership of a Cloth constraint

1 Select the Cloth constraint (in Outliner).

2 In the Cloth menu set, select Constraints > Edit Cloth Constraints 
Membership.

3 Do the following:

• Shift+click to add items (for example, vertices, points).

• Ctrl+click to remove items (for example, vertices, points).

Edit the point assigner 

The point assigner is created when you constrain cloth vertices. It 
determines the actual set of vertices that are constrained as the resolution 
of the cloth changes.

Set the resolution method

The resolution method attribute of the point assigner lets you choose the 
method of vertex assignment.

To set the resolution method

1 Select the constraint.

2 Do one of the following:

• In the Channel box, click pointAssigner.

• Display the Attribute Editor and click the pointAssigner tab.

3 From the Resolution Method pulldown menu, select one of the 
following: One-to-one or Boundary. For descriptions of these 
attributes, see ”Point Assigner node” on page 94.

4 If you select the Boundary resolution method, you can set the 
following two attributes in the Attribute Editor: Use Radius and 
Boundary Radius. For descriptions of these attributes, see ”Point 
Assigner node” on page 94.
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Edit the curve assigner 

The curve assigner is created when you constrain a panel curve. It lets you 
determine the start and end vertices that are constrained along the curve.

Set the start and end of a constrained curve 

You can constrain the entire panel curve or a percentage of the curve by 
setting the Start curve param and End curve param.

To set the start and end of the constrained curves

1 Select the constraint.

2 Do one of the following:

• In the Channel box, click curveAssigner.

• Display the Attribute Editor and click the curve Assigner tab.

3 Enter a value between 0 and 1 for the Start curve param and End 
curve param.

To constrain the entire curve, set the Start curve param to 0 and the 
End curve param to 1. To constrain the starting half of the curve, set 
the Start curve param to 0 and the End curve param to 0.5. To 
constrain the ending half of the curve, set the Start curve param to 0.5 
and the End curve param to 1.

Animate the start and end of a constrained curve

You can animate the Start curve param and End curve param over 
simulation time to create a tearing cloth effect. The following procedure 
animates the cloth constraint opening.

To animate the start and end of the constrained curves

1 At the starting frame, set the Start curve param to 0 and the End curve 
param to 1.

This constrains the entire curve.

2 Set keys for these attributes.

3 At the end of the animation, set the Start curve param to 0 and the 
End curve param to 1. Set keys for the attributes.

4 You can animate the cloth moving apart using transform constraints.
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Connect dynamic fields to your cloth

Because Cloth is fully integrated with 
Maya, you can use Maya’s dynamic fields 
to affect the motion of your cloth. You 
create the field the same way you create a 
field in Maya. You connect the field to 
cloth using a type of constraint known as 
a field constraint. You can connect field 
constraints to cloth vertices or panel 
curves.

 To connect a dynamic field to 
cloth

1 To create the field you want to use, 
from the Dynamics menu set, select Fields > Create  > fieldname. 

2 Do one of the following:

• If you are constraining cloth points, click the right mouse button 
over the cloth mesh and select Vertex. Select the vertex points you 
want to constrain.

• If you are constraining a panel curve, select the curve you want to 
constrain. 

3 Shift-Ctrl-click the field. 

4 From the Cloth menu set, select Constraints > Field. 

To adjust field constraint attributes

1 Select the constraint. 

Tip When you create the actual field, make sure you don’t have 
your cloth selected. 

Tips The magnitude of your field may be too low for the cloth 
animation. If you don’t see the field’s effect, increase the 
magnitude by a factor of 100.

Also, make sure the cloth is within the range specified by 
the Max Distance attribute of the field, and that Attenuation 
value is not so great that the cloth is not affected.
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2 In the Attribute Editor or Channel Box, set the attributes Constraint 
Weight and Size in the fieldConstraint Shape tab. For descriptions of 
these attributes, see ”Constraint Shape node” on page 92. 

 To delete field constraints

1 Do one of the following:

• Select the constraint in the view and delete it.

• Select the cloth. In the Outliner, open the cloth transform so you 
can see the transforms below it. Select the fieldConstraint and 
delete it. 

Reference Constraint Shape node

These are the attributes in the ConstraintShape node. For more 
information, see ”Use cloth constraints” on page 79.

Constraint Weight

Specifies whether the constraint is on or off. A value of 0 turns off the 
constraint. Any value greater than 0 turns on the constraint.

Size

Specifies the size the constraint is displayed on the screen. When the 
constraint is created, the size is based on the edge length of the 
triangle, which is determined by the resolution. The greater the 
resolution, the smaller the edge length and the smaller the constraint 
size.

Is Soft

(Transform constraint only) Specifies whether the constraint behaves 
like it’s rigid or soft. If you turn off Is Soft, the constraint behaves like 
a rigid bar is holding the cloth to the object to which it is constrained. 

If you turn on Is Soft, the constraint behaves like a spring. The rest 
length of the spring is its initial distance from the transform. The 
amount of elasticity is controlled by the Stiffness and Damping 
attributes.

Stiffness

Applies only if Is Soft is turned on. Specifies the amount of 
springiness of the constraint. The default value of 100 creates a 
constraint that is similar in springiness to a rubber band. You should 
increase this value by a factor of 10 to see different results. A value of 
100,000 creates a constraint similar to a steel rod.
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Damping

Applies only if Is Soft is turned on. Specifies how strongly the motion 
of the constraint is diminished by the physical properties of the 
constraint. Generally, the Damping value should be about 1/10 of the 
Stiffness value.

The higher the Damping value, the less the constraint jiggles back and 
forth. A high Damping value creates an effect similar to pulling a 
spring through maple syrup as opposed to air. It does not affect the 
magnitude of the initial force, which is specified by the Stiffness 
attribute.

Offset

(Cloth constraint only) Specifies the distance the constraint maintains 
between the source and target cloth. 

You use the Offset attribute to control which side 
of the cloth the pocket is constrained to, and how 
far the source cloth lies from the target cloth. A 
positive value offsets the cloth in the direction of 
the cloth’s normal. A negative value offsets in the 
opposite direction.

If you position the source cloth near the target 
cloth and the Offset is 0, the constraint pulls the 
source cloth into the target cloth when it is 
simulated. 

Collision Shape node

These are the attributes in the CollisionShape node. For more information, 
see ”Create collision constraints” on page 88.

Collision Constraint

These are the attributes in the Collision Constraint section of the 
CollisionShape node.

Size

Specifies the size of the square icon drawn for each vertex. 

Cloth Collisions

Set the Cloth Collisions attribute to on or off to enable or disable cloth-
to-cloth collisions for the selected vertices. Setting the cloth collisions 
to off can effectively untangle cloth in many cases. The default is off. 

Direction 
of normal

Offset
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Reference > Point Assigner node
Rigid Collisions

Set the Rigid Collisions attribute to on or off to enable or disable cloth-
to-collisions object collisions for the selected vertices. The default is 
off. 

Point Assigner node

These are the attributes in the PointAssigner node for constraints. For 
more information, see ”Edit the point assigner” on page 89.

Resolution Method

One-to-one Preserves the exact number of points that are 
constrained when you increase the resolution of the 
cloth mesh.

Boundary Preserves the boundary of the area specified by the 
selected points when you increase the resolution of 
the cloth mesh.

Use Radius

Specifies whether the boundary calculation is done automatically or 
whether you control the points in the boundary by specifying a 
boundary radius. 

If you turn off Use Radius, the radius is calculated for you, creating a 
continuous boundary of constrained cloth vertices.

If you turn on Use Radius, you must specify a value for the Boundary 
Radius.

Boundary 
resolution method

One-to-one 
resolution method

Original low-res
cloth mesh
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Reference > Constraints > Edit Constraint Membership Tool
Boundary Radius

For each selected cloth vertex, Cloth uses an imaginary circle to 
determine which points are constrained at a higher resolution. If the 
cloth vertex falls inside the circle of the radius specified, then it is 
constrained.

Constraints > Edit Constraint Membership 
Tool

Use this to add or remove points, vertices, etc. from the set of a Cloth 
constraint. For more information, see ”Edit constraints” on page 89.

Constraints > Transform

Use this to create a transform constraint that constrains the cloth to the 
object at a certain distance, as though it were welded. If the object moves, 
the points on the cloth that are constrained also move. For more 
information, see ”Create transform constraints” on page 79.

Constraints > Mesh

Use a mesh constraint to constrain cloth to a collision object. For more 
information, see ”Create mesh constraints” on page 81.

Constraints > Cloth

Use a cloth constraint to bind cloth vertices to cloth. For more information, 
see ”Create cloth constraints” on page 82.

Constraints > Field

Use this to connect a dynamic field to cloth. For more information, see 
”Connect dynamic fields to your cloth” on page 91.

Constraints > Collision

Use a collision constraint to let you control collisions on a per-vertex basis 
and animate the control over time. For more information, see ”Create 
collision constraints” on page 88.
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Reference > Constraints > Button
Constraints > Button

This creates a button constraint. When it is created a transform is created 
and updated every frame, which tracks the position and orientation of the 
cloth. You can parent an object to the transform and it will follow cloth 
like a button does. For more information, see ”Create button constraints” 
on page 84.

Constraints > Button > 

These are the options in the Button Constraint Options window.

Button Name

Enter a name for the button.

Preserve Translation

This preserves the position of the button in world space. The button 
does not move after the constraint is created

Translate

When Preserve Translation is turned off, you can set the translate X, 
Y, Z values.

Preserve Rotation

This preserves the offset of the button in world space. The button does 
not move after the constraint is created

Rotate

When Preserve Rotation is turned off, you can set the rotate X, Y, Z 
values.

.
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6 Playing back Cloth 
simulations
About Playing back Cloth simulations

When you run your simulation, you can cache the results for quick 
playback. You can save different cache files for the same scene to compare. 
You can speed up playback by disabling the solver or the collision objects.

Related topics

”Visualize stress on cloth” on page 97

”Manage cache files” on page 98

”Speed up playback” on page 104

”Fix playback and simulation problems” on page 104

How do I? Visualize stress on cloth

You can get visual feedback on areas of the cloth where there’s stress, as 
defined by the cloth solver. The cloth solver monitors the energy of the 
cloth on a per-vertex basis. With the Stress Visualizer you can see the 
stress areas reported by the solver.

Once you know the problem area of the cloth, you can frequently prevent 
the problem by increasing cloth resolution in that area, adding collision 
constraints, or modifying the collision geometry.

To show cloth stress

1 Select the cloth object or garment.
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How do I? > Manage cache files
2 In the Cloth menu set select Simulation > Show Cloth Stress.

Make sure the display is in shaded mode (press 5) and the locator 
nodes are showing (Show > Locators).

3 Play the simulation.

At the zero frame there will be no stress because this is the initial state 
of the cloth. Once you start the simulation you will notice the cloth 
mesh displaying shaded areas; by default, white represents areas of 
high stress and black represents areas of low stress.

For descriptions of the attributes in the cpClothStress node, see 
”cpClothStress node” on page 108.

To hide cloth stress

1 Select the cloth object or garment.

2 In the Cloth menu set select Simulation > Hide Cloth Stress.

Manage cache files

When you simulate cloth by playing through the time slider, Cloth creates 
a cache file to store all the positions of the vertices of the cloth. The cache 
lets you quickly preview the results of the cloth simulation without 
having to render to a flipbook. This offers many benefits, including 
scrubbing back and forth in the time slider and re-using a cache so you 
don’t have to solve at render time.

If caching is enabled, the solver writes the cache file to a temporary file. 
When you save the file, the temporary cache file is renamed to the cache 
filename and saved with the file. Cloth cache files have the mcc file 
extension.

The lighter shading 
represents areas of high 
stress on the table cloth.
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How do I? > Manage cache files
You can have more than one cache per solver and switch between caches 
dynamically. You can examine different simulations without having to 
load new caches to view them. Plus you can copy, blend, and interpolate 
caches over a range of frames.

All Cloth cache information is stored in the cpCache node. The default 
cache is attached to the cpSolver node.

”Create a cache” on page 99

”Switch between caches” on page 99

”Delete and truncate the cache” on page 100

”Compress the cache” on page 100

”Interpolate the cache” on page 101

”Use the Cache Editor” on page 101

”Save and load cache files” on page 103

Create a cache 

To create a cache

1 To make sure caching is enabled, go to the cpCache node (Simulation 
> Caches > cpCache) in the Attribute Editor and make sure Cache 
Enabled is turned on.

2 Make sure your start frame in the time slider is frame 1.

3 In your Animation preferences, make sure Playback Speed is set to 
Free and Playback by is set to 1.

4 Press the play button to run the simulation by playing through the 
time slider.

To create a new cache

Select Simulation > Caches > Create Cache. 

A new, empty cache is created and it becomes the current cache. You need 
to put data into the cache either by running a simulation or editing the 
cache.

Switch between caches

Each solver can have multiple caches, but solvers cannot share caches. 

To switch between caches in a solver

Select Simulation > Caches and then select the desired cache.
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Delete and truncate the cache 

If you want to re-evaluate a part of your scene, you need to delete the 
cache on your cloth. To do this, you can use one of two methods: Delete 
Cache or Truncate Cache. Delete Cache deletes the entire cache for the cloth 
object; Truncate Cache deletes the cache from the current frame forward.

To delete a cache

1 If you have more than one solver in the scene, select the cloth 
belonging to the solver whose cache you want to delete.

2 Select Simulation > Delete Cache.

The entire cache for the cloth object is deleted. 

To truncate a cache

1 If you have more than one solver in the scene, select the cloth 
belonging to the solver whose cache you want to truncate.

2 Select Simulation > Truncate Cache.

The cache from the current frame forward is deleted.

Compress the cache

The cache file can become quite large for scenes with many cloth bodies or 
highly tessellated cloth bodies, especially for longer animations. If you are 
satisfied with the simulation stored in the cache, you can reduce its cache 
file size by compressing the cache. 

A cache file stores position and velocity data for all cloth objects 
associated with a particular cloth solver. When you compress a cloth cache 
file, you remove all velocity data from the cache except for the last frame 
in the cache. This final set of velocities is required to restart the simulation 
from the end of the cache. As newly simulated frames are appended to the 
end of a compressed cache, both their position and velocity values are 
saved. So caches may be not completely compressed. 

You can play back a compressed cache and continue a simulation from the 
end of a compressed cache. But you can’t truncate a compressed cache 
and restart the simulation from a frame that has been compressed. 
Compressing the cache does not slow down playback performance.

To compress the cache

1 If you have more than one solver in the scene, select the cloth 
belonging to the solver whose cache you want to compress.

2 Select Simulation > Compress Cache.
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How do I? > Manage cache files
Interpolate the cache

Use this to smooth the cloth’s position at the frame(s) in the selected time 
range.

To interpolate cache data

1 Select the cloth and then select the time range (shift-drag in the Time 
Slider). 

2 Select Simulation > Interpolate Cache. This interpolates the current 
cache between the selected time range.

Use the Cache Editor

Using the Cache Editor you can interpolate, blend or copy cache frames 
from different simulations in the same solver. This reduces the number of 
simulations needed to produce a good cloth simulation.

To edit a cache you need the following:

• an edit operation (copy, blend, interpolate)

• a collection of source cache segments

• a target cache segment

An edit operation takes a series of source cache segments and produces a 
result in the target cache segment. A cache segment is made up of a cache 
node, range, and, optionally, a weight. Cache segments indicate what part 
of a cache to manipulate in the operation. The weight specifies how much 
of the cache segment you want to keep. In an operation all of the cache 
segments are normalized so their sum equals one.

The operation acts on the cache segments and combines the results into a 
target cache segment, which again specifies a cache node and a range, but 
not a weight.

Cache segments can start at different frames, but cannot be different in 
length (duration). In non-linear editing this is known as scaling and is not 
currently supported.

If a target cache segment is not specified then the default target is the 
same as the first source cache segment. 

Note You can also interpolate cache data using the Cache 
Editor. With the Cache Editor you can specify the 
type of interpolation as either linear or sine. See 
“Use the Cache Editor.”
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To open the Cache Editor

Select Simulation > Cache Editor.

The Cache Editor window appears. For descriptions of the options in the 
Cache Editor window, see ”Simulation > Cache Editor” on page 106.

To interpolate caches using the Cache Editor

1 Select Simulation > Cache Editor. The Cache Editor window appears.

2 Click the Add Cache Segment button. This adds a panel in the Cache 
Editor window for you to set the options for the source cache segment. 
You can only have one source cache segment when interpolating.

3 Set the options for the source cache segment. 

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames.

6 Select interpolate from the Operation drop-down list.

7 Select an Interpolation Type from the drop-down list.

Linear

Specifies linear interpolation from the start of a cache segment range 
to the end.

Sine

Favors values close to the start and end of the cache segment range 
and follows a more linear interpolation in the middle.

8 Click Apply or Apply and Close.

To blend caches using the Cache Editor

1 Select Simulation > Cache Editor. The Cache Editor window appears.

2 Click the Add Cache Segment button. This adds a panel in the Cache 
Editor window for you to set the options for the source cache segment. 
Add as many source cache segments as you need.

3 Set the options for each source cache segment, including the blend 
weight. Each range must be the same duration.

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames. The range must be the same 
duration as the source cache segments.

6 Select blend from the Operation drop-down list.

7 Click Apply or Apply and Close.
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How do I? > Manage cache files
To copy frames between caches using the Cache Editor

1 Select Simulation > Cache Editor. The Cache Editor window appears.

2 Click the Add Cache Segment button. This adds a panel in the Cache 
Editor window for you to set the options for the source cache segment. 
You can only copy one segment at a time.

3 Set the options for the source cache segment. 

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames. The range must be the same 
duration as the source cache segment.

6 Select copy from the Operation drop-down list.

7 Click Apply or Apply and Close.

Save and load cache files

You can save different cache files for the same scene. For example, if you 
are experimenting with different property values, you can save the cache 
using one set of values, change the values, re-run the simulation, and save 
the cache under a new name. You can then load a cache file that has 
already been created.

To name and save a cache file

1 In the cpCache tab of the Attribute Editor, enter a name for the cache 
in the Cache Name box.

Cloth cache files have.mcc extensions. If you don’t enter a name, 
scenefilename.mcc is used. 

2 Play the simulation.

3 Save the file.

To rename a cache file

1 In the cpCache tab of the Attribute Editor, enter a new name for the 
cache.

2 Save the file.

To load a cache file

1 In the cpCache tab of the Attribute Editor, click the folder button next 
to the Cache Name box.

2 In the browser, select the cachefile.mcc you want to load.

3 Click the Open button.

The cache file is loaded into the scene.
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Speed up playback

Disable/enable the solver

Sometimes you may want to disable the solver so you can keep animating 
other parts of your scene without the solver trying to evaluate. 

To disable/enable the solver

1 Select Simulation > Disable Solver. 

Now you can animate without solving for cloth. 

2 Select Simulation > Enable Solver to turn the solver back on. 

Disable cloth collisions

You can disable cloth-to-cloth collisions to speed up playback.

To disable cloth-to-cloth collisions

1 Select Simulation > Solvers > cpSolvernumber > .

2 Turn off Cloth Collisions.

Fix playback and simulation problems

• ”Use cloth with very fast motion” on page 104

• ”Cloth not solving” on page 105

• ”Cloth animation stops moving” on page 105

See also ”Advanced solver performance tools” on page 117.

Use cloth with very fast motion

When you run a cloth simulation, the vertex positions of the collision 
objects that the cloth collides with are sampled once per frame. If you 
have very fast motion, you may want to increase the frequency of the 
sampling. 

You can animate the frame sampling value, setting a higher value for the 
specific frame range in which the rigid bodies are moving quickly.

Note The cache file will not open if the geometry in the cache file 
does not match the geometry in the scene file.
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To increase the frame sampling rate

1 Select the cloth.

2 In the Channel Box, select cpSolver and display the Attribute Editor.

3 In the Frame Samples box, enter a value greater than 1. 

The number you enter determines the number of times per frame that 
the solver samples the vertex positions of the rigid body. This 
attribute has a large impact on performance. Typical values are in the 
range of 1 to 4.

Cloth not solving

If you play or render an animation and do not start at the first frame of the 
animation, cloth will not solve because the cloth solver does not handle 
run-up. 

The following warning message displays when this situation occurs:

// Warning: Cloth cannot solve because run-up is not 
supported: please restart playback or rendering from the 
first frame of the animation.//

The solution

1 Do one of the following:

• Rewind and play from the start.

• When rendering, re-render from the start of the animation.

Cloth animation stops moving

If frames are skipped when solving, the solver will stop, with the effect 
that your cloth animates for a few frames and then stops moving. This can 
occur during playback if your playback mode allows frames to be skipped 
or when rendering when the frame increment is something other than 
one. 

The following warning message is displayed when this situation occurs:

// Warning: Cloth cannot solve because increment between 
frames is not one: ensure playback mode or rendering 
increment does not skip frames.//

The solution

1 Do one of the following:

• Click the Animation Preferences button and set the Playback 
Speed to Play every frame;

• When rendering, set your rendering frame increment to one.
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Reference Simulation > Caches > Create Cache

Use this to create a cache. For more information, see ”Create a cache” on 
page 99.

Simulation > Delete Cache

Use this to delete a cache. For more information, see ”Delete and truncate 
the cache” on page 100.

Simulation > Truncate Cache

Use this to truncate a cache. For more information, see ”Delete and 
truncate the cache” on page 100.

Simulation > Compress Cache

Use this to compress a cache. For more information, see ”Compress the 
cache” on page 100.

Simulation > Interpolate Cache

Use this to interpolate the specified time range of a cache. For more 
information, see ”Interpolate the cache” on page 101

Simulation > Cache Editor

This opens the Cache Editor window. Use this to blend, interpolate, or 
copy frame ranges from different caches into a target cache. For more 
information see “Use the Cache Editor.” The following are descriptions of 
the options in the Cache Editor window.

Add Cache Segment

Click this button each time you want to add a source cache segment. 
Then set the source cache segment’s options.

Cache Select the cache for the source cache segment.

Range Specify a range of frames for the source cache 
segment.

Weight Specify a weight if you are blending cache segments.

Target Cache

Select a target cache from the drop-down list.
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Reference > Simulation > Disable Solver
Target Range

Specify the start and end frame in the target cache. The duration of 
this frame range must be the same as the source range(s). For 
example, the source range could be frames 1 to 5 and the target range 
could be frames 21 to 25.

Operation

Select an editing operation from the drop-down list.

Interpolate Removes the cloth particle's position at the frame(s) 
as specified in the Source Cache and Source Range 
and uses the previous and following positions of the 
particle(s) to calculate a new position. The 
interpolation type determines how the values are 
calculated. Interpolation only works with a single 
Source Cache.

Blend Based on a specified blend weight, combines 
specified equal duration frame ranges from different 
simulations into the target cache segment at the 
specified range. Set the blend weight in the source 
cache segment options. Weighting values are 
normalized so the sum of cache segment weights 
equals 1.0. The source and target ranges can be in 
different caches.

For example, combine frames 1 to 5 of one 
simulation and frames 6 to 10 of another simulation 
into frames 21 to 25 of the target simulation. 

Copy Copies the specified frame range in the source cache 
segment to the specified frame range (of equal 
duration) in the target cache segment.

Interpolation Type

If you select interpolate as your editing operation, you’ll need to select 
a type of interpolation.

Linear Specifies linear interpolation from the start of a 
cache segment range to the end.

Sine Favors values close to the start and end of the cache 
segment range and follows a more liner 
interpolation in the middle.

Simulation > Disable Solver

Use this to turn off the solver. For more information, see ”Disable/enable 
the solver” on page 104.
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Simulation > Enable Solver

Use this to turn on the solver. For more information, see ”Disable/enable 
the solver” on page 104.

Simulation > Show Cloth Stress

Use this to turn on the display of stress feedback on the cloth. For more 
information, see ”Visualize stress on cloth” on page 97.

Simulation > Hide Cloth Stress

Use this to turn off the display of stress feedback on the cloth. For more 
information, see ”Visualize stress on cloth” on page 97.

cpClothStress node

These are the attributes in the Cloth Stress Visualization section of the 
cpClothStress node. For more information, see ”Visualize stress on cloth” 
on page 97.

High Stress Color

This color in the Stress Visualizer represents areas of high stress. The 
default color is white.

Low Stress Color

This color in the Stress Visualizer represents areas of low stress. The 
default color is black.

Draw Type

This defines how the stress will be displayed on the cloth object or 
garment. The drop-down list includes: Default, Shaded, and Numeral. 

Default If you are in Wireframe mode, stress is displayed as 
Numeral by default; if you are in Shaded mode, 
stress is displayed as Shaded by default.

Shaded This applies only when you are in Shaded (as 
opposed to Wireframe) mode. Areas of stress are 
represented by colors, as defined by the High Stress 
Color and Low Stress Color attributes.

Numeral Areas of stress are annotated with values 
representing the level of stress. These values are the 
normalized values from the solver; high areas are 
close to 1.0 and low areas are close to 0.0.
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Reference > cpClothStress node
Disable Cutoff

This is available only when the Numeral Draw Type is selected. By 
default this checkbox is turned off. When it is turned on the Cut Off 
value is disregarded and all stress values are displayed in the Stress 
Visualizer. This can result in a cluttered display.

Cut Off

This value is a lower limit on what numerals are displayed in the 
Stress Visualizer. The default value is 0.5; in this case only stress 
values of 0.5 and higher are displayed.

Stress Scale Factor 

In large cloth objects or garments, the normalization of stress values 
can hide stress. With Stress Scale Factor you can increase or decrease 
the stress factors to better see the stress. The default is 1.

actual = Stress_Scale_Factor * normalized_stress_value

Mesh Draw Offset

This is only for the Shaded Draw Type. Use this to better see the 
stress. The cloth object or garment is drawn n-units closer to or farther 
from the user in the viewing direction. For example, if the Mesh Draw 
Offset was 1, but then increased to 2, the cloth would be drawn 1 unit 
closer in the user’s viewing direction. The default is 0.05. 
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Reference > cpClothStress node
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7 Adding texture and 
shaders to Cloth
About Adding texture and shaders

Textures and shaders add lifelike realism to your cloth. You use the 
standard Maya tools to add texture and shaders to your cloth just like you 
add them to any object in Maya. Find out more about shaders and textures 
that are unique to cloth:

• ”Create non-overlapping texture coordinates” on page 111

• ”Adjust texture coordinates” on page 113

• ”Use double-sided shaders” on page 114

• ”Use patterns” on page 114

How do I? Create non-overlapping texture coordinates 

In Cloth, UV texture coordinates are generated by taking a bounding box 
of all the panels that form the garment and normalizing their values 
between 0 and 1 using a uniform scale. The UV texture coordinates will 
not be squashed or stretched relative to each other as they are scaled into 
the 0 to 1 range. Either the height or width of the garment, whichever is 
greater, defines the scale of the texture.

To create non-overlapping UV texture coordinates

1 Create your curves, all under one hierarchy.
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For example, create the curves either all under one group or under the 
world.

2 Select the curves. Select Edit > Duplicate > .

3 In the Duplicate Options window, turn on Instance and click 
Duplicate.

4 Group the curves as needed to organize your garment.

For example, group the original curves and the instanced curves.

5 Position the instanced curves around the character.

6 Create your cloth panels and seam the garment.

7 Assign a shader to the cloth.

To view the texture coordinates

1 Select the cloth garment.

2 From the Modeling menu set, select Window > UV Texture Editor.

Original Curves Instanced Curves 
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3 To tailor the garment, you can do the following:

• To move the curves and modify the UV texture coordinates, select 
the vertices of either the original curves or the instanced curves in 
the scene view and move them.

• To move your curves without modifying the UV texture 
coordinates, select the groups of the instanced curves and move 
them.

Adjust texture coordinates

You can move selected UV texture coordinates (UV points) to modify 
selected parts of your texture map. You use the UV Texture Editor to do 
this.

As you adjust the UV points, the way the image is mapped onto the object 
changes accordingly. You manipulate UV points of the model in the UV 
Texture Editor without actually changing the UV points of the object in 
the 3D view. The idea is to stretch and squeeze parts of the 2D object so 
that they match up with the equivalent parts of the 3D object. The 3D view 
reflects your changes as you make them in the UV Texture Editor. 

For information on moving texture coordinates using the UV Texture 
Editor, see the Polygonal Modeling guide.

  Instanced CurvesOriginal CurvesUV Texture Editor

Note If you manipulate texture coordinates downstream from the 
solver, these coordinates will be incorrect if you change the 
cloth resolution. Make sure your cloth is at its final 
resolution.
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Use patterns

Cloth looks best when you use a texture with a repeatable pattern. For a 
pattern to be repeatable, you must be able to tile it without it appearing to 
obviously repeat. The texture should have no edge lines and no obvious 
indications of a repeating texture that make it look like a small texture that 
has been copied and duplicated. 

If you have a pattern that is non-repeating, you need to make it 
repeatable. That usually entails taking it into a paint package and 
adjusting it so it doesn’t look obviously “tiled.”

Use double-sided shaders

You can create double sided shaders to apply a 
different shader to each side of a two-sided 
garment. For example, you could use a double-
sided shader to apply satin lining to a tweed 
vest.

For information on creating double-sided 
shaders, see ”Use double-sided shaders” on 
page 114 in the Shading guide. 
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scenes
About Managing Cloth scenes

You can use these techniques to manage your cloth simulation scenes:

• ”Export and import garments” on page 115

• ”Advanced solver performance tools” on page 117

• ”Use multiple solvers in a scene” on page 120

• ”Simulate cloth in batch mode” on page 123

How do I? Export and import garments

You can export a garment with or without its solver. You can also export a 
garment with or without its collision object. 

If you export a garment without the solver, you get the polygonal mesh of 
the cloth after it has been simulated. The cloth can no longer be simulated. 
For example, you could simulate a tablecloth and export it without the 
solver to use it in a restaurant scene where the tablecloth doesn’t have to 
simulate.

If you export a garment with the solver, you get the solver and all the 
garments that are connected to the solver. For example, if you create a 
shirt and pants connected to the same solver, then you export the shirt 
with the solver, the pants are also exported. If you don’t need the pants, 
you can delete them when you import the garment. Alternatively, you can 
transfer the garment you want to export to a separate solver (see ”Use 
multiple solvers in a scene” on page 120).
Cloth

115



8 | Managing Cloth scenes
How do I? > Export and import garments
To export a garment with the solver

1 Select the garments you want to export.

The garments will be disconnected from their collision objects during 
export.

2 Select File > Export Selection > .

3 In the Export options box, turn on the History checkbox.

4 Click the Export Selection button.

5 Enter a name for the new scene.

The scene will contain the exported items.

To export a garment without the solver

1 Select the garments you want to export.

The garments will be disconnected from their collision objects during 
export.

2 Select File > Export Selection > .

3 In the Export options box, turn off the History checkbox.

4 Click the Export Selection button.

5 Enter a name for the new scene.

The scene will contain the exported items.

To export a garment and its collision object

1 Select the garment and the collision object.

2 If you want to export the solver also, select File > Export Selection >  
and turn on the History checkbox.

3 Click the Export Selection button.

4 Enter a name for the new scene.

The scene will contain the exported items.

 To import a garment

1 Select File > Import.

2 Navigate to the file that contains the garment you want to import.

3 Click Import.

Reset initial position 

If you want to import a garment that was modeled at the origin and place 
it on a character that is not at the origin, use Save as Initial Cloth State.
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To reset initial position

1 Import the garment.

The garment must have been exported with History turned on.

2 Select the cloth mesh and position the garment on the character.

You can drag the cloth using the Move tool, or you can copy the 
transformation values of the character and enter the values in the 
Channel Box.

3 Make sure the cloth is still selected. Select Simulation > Save as Initial 
Cloth State.

The current cloth vertex positions are saved in the solver, and the 
cloth transform is reset to the origin. 

Advanced solver performance tools

• ”Monitor script parameters” on page 117

• ”Reasons for solver failure” on page 118

• ”Solver diagnostics” on page 119

Monitor script parameters

To take advantage of the MEL callback, your MEL routine must have the 
following parameters: 

• string $solverName - This tells the callback the name of the solver that 
called it. 

• int $failureReason - This tells the callback the reason of failure. See 
”Reasons for solver failure” on page 118.

• string $optionString - This string is reserved for future parameters. 

These arguments must be the last three arguments of your MEL callback. 
You can have additional parameters, but they must occur before the above 
parameters. 

Here is a sample callback:

global proc myReact( int $stepsBack, string $solverName, int 
$reason, string $optionVar )
{ 
print ("User defined script called" + $i + "\n"); 
print ("solverNode = " + $solverNode + "\n"); 
print ("reason = " + $reason + "\n"); 
print ("option = " + $option + "\n"); 

float $by = `playbackOptions -query -by`; 
float $curr = `currentTime -query`; 
float $min = `playbackOptions -query -min`; 
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float $max = `playbackOptions -query -max`; 

float $theStep = $stepsBack * $by; 

if (($curr != $min) && 
(($curr - $theStep) >= $min) && (($curr - $theStep) < $max)) 
{ 
currentTime -edit ($curr - $theStep); 
}

// Truncate the cache at the current time. 
// 
cpSolver -e -deleteRestOfCache; 

// Set frame samples to be 1. 
// 
string $plug1 = ($solverNode + ".frameSamples"); 
setAttr $plug1 1; 

// Play forward 
play; 
} 

monitorString attribute would equal myReact x where x would equal the 
number of frames you would want to step back.

Reasons for solver failure

There can be a few reasons for failure. These reasons equate to the internal 
fail detector in the solver node. 

1 Bad Cutoff - The cutoff value is a double precision value that 
represents, approximately, the amount of stress in the cloth. Very 
large cutoff values are usually an indication of a bad cloth 
configuration. When the cutoff value exceeds the internal threshold, 
the fail detector reports the problem and a response is taken. When 
$failReason equals 1 this implies a large cutoff value occurred and the 
detector requested that the solver stop. 

2 Bad Adaptive Step - To solve a single frame the solver makes several 
steps within that frame to get a solution. Internally the solver has a 
mechanism for determining how large, or small, of a step it should 
take to get a solution. This is known as adaptive stepping. If the 
adaptive step size becomes too small, then the frame may not 
complete in a reasonable amount of time. The detector looks for cases 
where the adaptive size is very small and reports this. When 
$failReason equals 2 this implies a very small adaptive step was 
encountered. 
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Solver diagnostics

The solver node monitors solver performance through a series of solver 
callbacks. These callbacks indicate how well the solver is performing. 
There are three types of callbacks that represent performance. 

• Adaptive Step Notification 

In midstep the solver may decide that it would be appropriate to 
restart the current step at a smaller time increment (recall that solver 
takes several steps between frames to compute the output mesh for a 
given frame). When the solver makes this internal adjustment it 
notifies the solver node. The solver node records this for analysis. 
Very small steps are indication the solver is having difficulty finding a 
solution for the frame. 

• Collision Detection Notification 

This callback indicates that collision detection is being performed. The 
solver tells the solver node the maximum amount of penetration 
found from a collision. 

• Linear Solution Notification 

The solver uses a linear solver to determine the output mesh. This 
callback is invoked several times during this solution process. 
Encoded in the callback information is a cutoff value. This value 
roughly indicates the amount of stress in the simulation. Large values 
indicate poor cloth configuration. These values are recorded by the 
solver node and used for diagnostic purposes. 

Extracting and interpreting the diagnostic data

You can extract the recorded callback information after a simulation has 
stopped, either from the completion of playback or from fail detection. To 
extract information use the following command:

cpSolver -wsh "/path/fileName"

The solver command extracts the data from the solver node and stores it 
in the file you specify. A .cbd extension will be added to the name of that 
file. 

The output .cbd file contains four columns. 

• The first column is the time instance that the callback data was 
sampled from. The time corresponds to the current time units. 

• The second column is the cutoff parameter returned from the linear 
solution callback. 

• The third column is the maximum penetration value returned from 
the collision callback. 

• The final parameter is the array of adaptive step notifications. 
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Use multiple solvers in a scene

It can be computationally expensive to simulate several clothed characters 
at the same time. To reduce this problem, you can segment the cloth 
simulations into multiple independent simulations that are solved 
separately. You do this by using multiple solvers.

If two garments will not be colliding with each other, you can place them 
in separate solvers. You can turn a solver on or off independently of the 
other solvers. This lets you work on the simulation of one garment 
without having to wait for other simulations to solve. 

In addition, caching is performed on a per-solver basis. This means you 
can build your animation in stages by solving simulations one at a time. 
You can view the previously solved simulations with the one you are 
currently working on.

Create multiple solvers

To create a new solver

1 Do one of the following:

• Select Simulation > Solvers > Create Solver.

• Select Simulation > Solvers > Create Solver > , modify the 
settings in the Cloth Solver Options window, and then click 
Create. For information about these options, see ”Simulation > 
Solvers > Create Solver > ” on page 124.

A new cloth solver is created and added to the list of solvers in the 
Cloth Solver menu. This new solver becomes the current solver. You 
can rename the solver in the Channel Box.

Select the solver

You specify which simulation you want to work on by making its solver 
the current solver. All subsequent construction operations are applied to 
that simulation. 

To make a solver current

• Select Simulation > Solvers > cpSolvername. 

The solver you select becomes the current solver. Any garments, cloth 
objects, and collision objects you create while this solver is current are 
controlled by this solver.
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Edit multiple solvers

To change the solver’s attributes

1 Select Simulation > Solvers > cpSolvername > .

The solver attributes are displayed in the Attribute Editor.

2 Enter values for the attributes (see ”Adjust the cloth solver” on 
page 53 for information on the solver attributes).

Turn multiple solvers on or off

To disable a solver

1 Do one of the following:

• Select Simulation > Solvers > cpSolvername > . Turn off Solver 
Enabled in the options window. 

• Select the cloth belonging to the solver you want to disable. Select 
Simulation > Disable Solver. 

To enable a solver

1 Do one of the following:

• Select Simulation > Solvers > cpSolvername > . Turn on Solver 
Enabled in the options window. 

• Select the cloth belonging to the solver you want to enable. Select 
Simulation > Enable Solver. 

Transfer garments between solvers

To transfer a garment from one solver to another

1 Make the solver you want to transfer the garment to current by 
selecting Simulation > Solvers > cpSolvername. 

The solver you select becomes the current solver. 

2 Select the garment you want to transfer to the current solver.

3 Select Simulation > Transfer Garment.

The garment is connected to the current solver.

Important!

When you transfer garments from one solver to another, 
the cache files of both solvers become invalid. You must 
resimulate using each solver to create new cache files.
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Delete cache with multiple solvers

To delete the cache in scenes with multiple solvers

1 Select the cloth. 

2 Select Simulation > Delete Cache. 

Cloth ignores the current solver, finds the solver for the selected cloth, 
and deletes the cache.

Use collision objects with multiple solvers

A collision object can be connected to more than one solver. Before 
creating or removing collision objects, you must select the solver that the 
collision object is connected to.

The collision object attribute settings apply to all the solvers that the 
collision object is connected to. 

To create a cloth collision object

1 Select Simulation > Solvers > cpSolvername

where cpSolvername is the name of the solver to which you want to 
add the collision object. 

This makes it the current solver.

2 Select the object you want to be a collision object. 

3 With the object still selected, select Cloth > Create Collision Object.

The object is made a collision object and connected to the current 
solver.

To remove a cloth collision object

1 Select Simulation > Solvers > cpSolvername

where cpSolvername is the name of the solver from which you want to 
remove the collision object. 

This makes it the current solver.

2 Select the collision object.

3 Select Cloth > Remove Collision Object.

To transfer a collision object from one solver to another

1 Select Simulation > Solvers > cpSolvername

where cpSolvername is the name of the solver from which you want to 
remove the collision object. 

This makes it the current solver.
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2 Select the collision object.

3 Select Cloth > Remove Collision Object.

The object is no longer a collision object of the first solver.

4 Make the new solver current by selecting Simulation > Solvers > 
cpSolvername

where cpSolvername is the name of the solver that you want to add the 
collision object to. 

This makes it the current solver.

5 Select the object and select Cloth > Create Collision Object.

The object becomes a collision object connected to the new solver.

Simulate cloth in batch mode

We’ve included a script, cpRunBatch.mel, which lets you solve a cloth 
animation in batch mode. You can use this script to create the cache file 
without having to run Maya graphically.

Simulate cloth in batch mode with a floating license

When simulating cloth in batch mode, Maya acquires the simulation 
license when it reaches the first frame that requires cloth simulation. In a 
floating license installation, the license acquisition during batch mode can 
fail if another user starts a Maya Unlimited interactive session on another 
machine and exhausts the supply of licenses before the cloth content is 
reached. To prevent this, we’ve included the environment variable 
MAYA_CLOTH_SIMULATE.

If you set this variable before you start the batch simulation, Maya loads 
the simulation license at the start of the batch mode, which ensures that a 
simulation license is reserved by the time the cloth frame is reached.

To set the MAYA_CLOTH_SIMULATE environment variable

1 Do one of the following:

• (IRIX and Linux) Type the following in a shell:

setenv MAYA_CLOTH_SIMULATE

• (Windows) Set the MAYA_CLOTH_SIMULATE environment 
variable in the Maya.env file. See “Setting environment variables 
using Maya.env” in the Environment Variables guide.

To simulate cloth in batch mode

1 Do one of the following:

• (IRIX and Linux) Type the following in a shell:
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maya -batch -file filename -command "cpRunBatch 
startframe endframe" 

• (Windows) Type the following in a DOS shell:

mayabatch.exe -batch -file filename -command 

"cpRunBatch startframe endframe" 

Simulate cloth in batch mode with a node-locked 
license

To simulate cloth in batch mode when you have a node-locked license, 
you need to use the node-locked license.

To simulate cloth in batch mode (IRIX and Linux)

• Type the following in a shell:

maya -batch -lic=unlimited -file filename -command 

"cpRunBatch startframe endframe" 

To simulate cloth in batch mode (Windows)

Create a batch file that sets the environment variable MAYA_LICENSE to 
unlimited, then use that batch file to create the cloth cache file.

1 Create a file called createCache.bat with the following lines.

set MAYA_LICENSE=unlimited

mayabatch.exe -batch -file "%1" -command 

"cpRunBatch %2 %3"

2 Then run the batch file, by typing:

createCache filename startframe endframe

Reference Simulation > Solvers > Create Solver

Lets you create a solver so you can segment cloth simulations into 
multiple independent simulations that are solved separately. For more 
information, see ”Use multiple solvers in a scene” on page 120.

Simulation > Solvers > Create Solver > 

Lets you specify the settings for the solver in the Cloth Solver Options 
window.
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Name

Enter a name for the solver.

Start Frame

Specify at what frame the solver starts calculating.

Frame Samples

Specify the number of times the solver samples the time interval 
between successive frames. Frame Samples and Time Step Size work 
together.

Time Step Size

Specifies the maximum time, in seconds, that the internal dynamic 
solution advances. Frame Samples and Time Step Size work together.

Solver Scale

Specifies the scale of the internal coordinate system of the solver. 

Gravity

Specifies the value for gravity. If you want to disable gravity, set this 
to 0, 0, 0. The default is 0, -980, 0.

Relax Frame Length

Specifies the number of frames that a rubbery “relax material” is 
applied to a garment and the garment does not react to gravity. After 
the specified number of frames, the normal material is applied and the 
cloth reacts to gravity. 

If you are creating a cloth object that does not need to be relaxed, such 
as a tablecloth, set the Relax Frame Length to zero.

If you are creating a cloth object that is really stretched out, you can 
increase this value.

Simulation > Transfer Garment

Use this to connect the garment to the current solver. For more 
information, see ”Transfer garments between solvers” on page 121.
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About Cloth cache format

A cache file stores position and velocity data for all cloth objects 
associated with a particular cloth solver. The Cloth cache file is in binary 
Big-Endian format for IRIX, Linux and Windows. All integers are 
represented as 8-byte integer data. 

The file consists of a header, followed by the body of the cache. The body 
contains position and velocity values of each cloth object connected to the 
associated solver for each frame that has been simulated. The header 
stores a magic number, so there is no restriction on cache filenames. In 
addition, the header stores a version number to allow the format to evolve 
over time. 

Compressed caches

You can compress caches, which removes some or all of the velocity data. 
The Compress Cache operation removes all velocity data from the cache 
except for the last frame in the cache. This final set of velocities is required 
to restart the simulation from the end of the cache. As newly simulated 
frames are appended to the end of a compressed cache, both their position 
and velocity values are saved. So caches may be not completely 
compressed. The header contains the number of compressed frames so it 
is possible to calculate the position of any frame in the cache. 
Compressing the cache does not slow down playback performance.

Header format 

The header starts with five 8-byte integers in the following order:

• magic number 

• version number 

• total number of frames 

• number of compressed frames 

Warning

When truncating a cache, it is not valid to truncate the 
cache to a frame that has been compressed. The format 
contains no delimiters between frames of data, so a poorly 
truncated frame uses the next frame’s positions as its 
velocities when being restarted by a solver.
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• number of cloth objects 

The magic number is 5463728 and will not change. The version number 
for Version 2 is 2. The total number of frames includes both compressed 
and uncompressed frames. The number of cloth objects must equal the 
number of cloth objects connected to the solver that use this cache. This 
includes both cloth objects that have been created from panels and cloth 
objects that have been created from existing polygonal meshes and 
NURBS surfaces.

Following these five integers is a set of 8-byte integers, one for each cloth 
object. These integers specify the number of vertices in each cloth object. 

The correspondence between the cloth objects represented in the cache 
and the cloth objects simulated in the solver is by the connection order of 
the cloth objects into the solver. The cloth solver node defines an input 
attribute called clothBody. This attribute is an array whose elements 
contain the connections from the cloth objects that will be used by the 
solver. 

The connections can be viewed using Maya’s Hypergraph or Connection 
Editor. The array can be sparse, so the first cloth object in the cache 
corresponds to the connection with the lowest array index. The next 
cached cloth object corresponds to the connection with the next lowest 
array index, and so forth.

The solver verifies that all of the data in the header matches the 
information in the solver, and that the magic number is correct and the 
solver recognizes the version of the cache. If any of this information is 
invalid, the cache will not be used by the solver.

Body format

Following the header is the body of the cache. The body stores the 
position and velocity data for each cloth object for each simulated frame. 

The figure below shows the organization of the data. All the data for a 
frame is grouped together. The order of the bodies is the same as the order 
specified in the header. The ordering of the positions and velocities is the 
same order as the vertex ordering of the shape as specified in Maya. 

Warning

The number of integers must be equal to the number of 
cloth objects specified. There is no delimiter between these 
integers and the body of the cache. An incorrect number of 
integers results in either header data being used in the body 
or vice versa.
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The frames are stored sequentially with the first frame after the header 
being the first frame simulated. The initial position of the cloth objects are 
not stored in the cache file. There must be at least one uncompressed 
frame. All position and velocity values are stored as 4-byte floating point 
data. There are no delimiters between any group of data.

2nd cloth 
positions

1st cloth 
positions

3rd cloth 
positions

Header

1st cloth 
positions

1st cloth 
velocities

2nd cloth 
positions

2nd cloth 
velocities

Uncompressed frames

Compressed 
frames
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About Cloth licenses

Each copy of Maya Unlimited comes with one edit license, one simulation 
license, and additional licenses for batch rendering. The edit license lets 
you use all the Cloth features, the simulation license lets you simulate 
cloth, and the licenses for batch rendering let you render cloth scenes in 
batch mode. 

The simulation license

The simulation license is used for:

• In interactive mode, the simulation license is acquired as soon as the 
Cloth plug-in is loaded. Therefore, when an interactive session of 
Cloth is running, you cannot render a cloth scene that requires cloth to 
be simulated. (This applies when floating licenses exist and all edit 
licenses are in use.)

• In batch mode, prompt mode, or when rendering, a simulation license 
is acquired only when cloth needs to be simulated. 

The Cloth plug-in does not release any of the licenses it acquires until you 
exit Maya. Unloading the Cloth plug-in does not release the licenses.

Cloth licenses and rendering 

The simulation license is used as follows for rendering:

• you can simulate while rendering (This requires a simulation license.)

• you can render a cloth scene that has already been simulated and has 
a cache file (This does not require a simulation license.)
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